summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Viguié2015-11-04 23:49:19 +0100
committerAlexis Viguié2015-11-04 23:49:19 +0100
commit265819f20657e859032979eb6bae745123f41631 (patch)
tree3b722ed9871c1d0ea8a89fb037b32a415c21d3b2
parent6ca3071844b559d67f752fd8e9886dd09bbf96da (diff)
downloadaur-265819f20657e859032979eb6bae745123f41631.tar.gz
corrected typo and fixed pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD35
2 files changed, 36 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e4705545632..0698432ce7be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = blih
- pkgdesc = Bocal Lighteweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students
+ pkgdesc = Bocal Lightweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students
pkgver = 1.7
pkgrel = 1
url = https://intra-bocal.epitech.eu
diff --git a/PKGBUILD b/PKGBUILD
index e69de29bb2d1..eb86874b288e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexis Viguié <alexis.viguie@epitech.eu>
+pkgname=blih
+pkgver=1.7
+pkgrel=1
+pkgdesc="Bocal Lightweight Interface for Humans, git repositories and
+SSH public keys management tool for EPITECH students"
+arch=('any')
+url="https://intra-bocal.epitech.eu"
+license=('GPL')
+groups=()
+depends=('python>=3.3.0' 'python-requests')
+makedepends=()
+optdepends=()
+provides=('blih')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://pkg.blinux.fr/pub/$pkgname/$pkgver/$pkgname-$pkgver.tgz)
+noextract=()
+md5sums=('8d737cc043bcd2217cfb89ab84882ceb')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cat blih.py | sed -e s/python3.3/python/ > blih
+ chmod 755 blih
+}
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ cp "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin"
+}