summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Viguié2015-11-04 17:56:33 +0100
committerAlexis Viguié2015-11-04 17:56:33 +0100
commit2ab4fc78e34b6a793f614d398f04817692566acd (patch)
treed49ce51b88fec13fda42b4ba0e8d61fb1b47026b
downloadaur-2ab4fc78e34b6a793f614d398f04817692566acd.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e4705545632
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blih
+ pkgdesc = Bocal Lighteweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://intra-bocal.epitech.eu
+ arch = any
+ license = GPL
+ depends = python>=3.3.0
+ depends = python-requests
+ provides = blih
+ source = https://pkg.blinux.fr/pub/blih/1.7/blih-1.7.tgz
+ md5sums = 8d737cc043bcd2217cfb89ab84882ceb
+
+pkgname = blih
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ced5df449d52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexis Viguié <alexis.viguie@epitech.eu>
+pkgname=blih
+pkgver=1.7
+pkgrel=1
+pkgdesc="Bocal Lighteweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students"
+arch=('any')
+url="https://intra-bocal.epitech.eu"
+license=('GPL')
+groups=()
+depends=('python>=3.3.0' 'python-requests')
+makedepends=()
+optdepends=()
+provides=('blih')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://pkg.blinux.fr/pub/$pkgname/$pkgver/$pkgname-$pkgver.tgz)
+noextract=()
+md5sums=('8d737cc043bcd2217cfb89ab84882ceb')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cat blih.py | sed -e s/python3.3/python/ > blih
+ chmod 755 blih
+}
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ cp "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin"
+}