summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo Bertacchini2018-09-02 20:18:01 +0200
committerTheo Bertacchini2018-09-02 20:18:01 +0200
commit2dc86679523556924b06141873c192c881f7ae62 (patch)
tree897c494f2e920aeb2ba498f40a7df4b66ad22ea1
parent4edcf43c3da0edf0d13401edc1130a09ba8c715c (diff)
downloadaur-2dc86679523556924b06141873c192c881f7ae62.tar.gz
Follow AUR packaging recommandations
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9452952bad4..c0d946af5dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,8 @@ pkgbase = blih
depends = python>=3.3.0
depends = python-requests
depends = git
- depends = sudo
provides = blih
- source = blih-1.7::https://github.com/bocal/blih/archive/v1.7.tar.gz
+ source = blih-1.7.tar.gz::https://github.com/bocal/blih/archive/v1.7.tar.gz
sha256sums = SKIP
pkgname = blih
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..796af1a519ad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+blih*
diff --git a/PKGBUILD b/PKGBUILD
index bf7066f225e1..4ddb863290b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,24 +8,23 @@ url="https://intra-bocal.epitech.eu"
license=('GPL')
depends=('python>=3.3.0'
'python-requests'
- 'git'
- 'sudo')
+ 'git')
provides=('blih')
-source=("${pkgname}-${pkgver}::https://github.com/bocal/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=("SKIP")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bocal/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
prepare() {
cd "${pkgname}-${pkgver}"
- sed -i s/python3.3/python/ ${pkgname}.py
+ sed -i s/python3.3/python/ "${pkgname}.py"
}
build() {
- cd ${pkgname}-${pkgver}
- mv ${pkgname}.py ${pkgname}
- chmod 755 ${pkgname}
+ cd "${pkgname}-${pkgver}"
+ mv "${pkgname}.py" "${pkgname}"
+ chmod 755 "${pkgname}"
}
package() {
mkdir -p "${pkgdir}/usr/bin"
- cp "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin"
+ cp -a "${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin"
}