summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Haar2019-11-25 16:38:39 +0100
committerLaurent Haar2019-11-25 16:38:39 +0100
commitc18cbda93a01dcb0325454fe1209417bd2fbf223 (patch)
tree01a271cd587baec6a92eb2c5749871f96c72b69d
downloadaur-c18cbda93a01dcb0325454fe1209417bd2fbf223.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e855f9d602c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blih-custom
+ pkgdesc = Bocal Lightweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://intra-bocal.epitech.eu
+ arch = any
+ license = BSD
+ depends = python>=3.3.0
+ depends = python-requests
+ depends = git
+ provides = blih
+ conflicts = blih
+ source = blih-custom-1.0.tar.gz::https://github.com/Seres67/blih-custom/releases/download/v1.0/v1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = blih-custom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d579c1f0389c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Laurent Haar laurent.haar@epitech.eu
+pkgname=blih-custom
+pkgver=1.0
+pkgrel=1
+pkgdesc="Bocal Lightweight Interface for Humans, git repositories and SSH public keys management tool for EPITECH students"
+arch=('any')
+url="https://intra-bocal.epitech.eu"
+license=('BSD')
+depends=('python>=3.3.0'
+ 'python-requests'
+ 'git')
+provides=('blih')
+conflicts=('blih')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Seres67/${pkgname}/releases/download/v${pkgver}/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ sed -i s/python3.3/python/ "${pkgname}/${pkgname}.py"
+}
+
+build() {
+ cd "${pkgname}"
+ mv "${pkgname}.py" "${pkgname}"
+ if [[ -z "${BLIH_USER}" ]]; then
+ echo "Please define BLIH_USER env var to your epitech mail address (firstname.lastname@epitech.eu)"
+ exit 1
+ fi
+ sed -i "s|BLIH_USER|\"$BLIH_USER\"|" "${pkgname}"
+ chmod 755 "${pkgname}"
+ mv "${pkgname}" "blih"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -a "${pkgname}/blih" "${pkgdir}/usr/bin"
+}