summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorutsi2015-11-03 15:48:59 +0100
committerutsi2015-11-03 15:48:59 +0100
commit2d3d4c7d24c63edf022cdd48610a4411fd711468 (patch)
treee839a2aa8a4011f4d7602cc2f3fc6ba5f992b3c9
downloadaur-2d3d4c7d24c63edf022cdd48610a4411fd711468.tar.gz
Initial import, PKGBUILD strips out documentation and examples
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1eb8ecb2b29d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blingbling-git
+ pkgdesc = Fancy Widgets, Popups and signals for Awesome WM
+ pkgver = 185.694029a
+ pkgrel = 1
+ url = https://github.com/cedlemo/blingbling
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = awesome
+ depends = lua-oocairo-git
+ provides = blingbling
+ source = git://github.com/cedlemo/blingbling.git
+ md5sums = SKIP
+
+pkgname = blingbling-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f17cd3804b4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=blingbling-git
+pkgver=185.694029a
+pkgrel=1
+pkgdesc="Fancy Widgets, Popups and signals for Awesome WM"
+arch=('any')
+url="https://github.com/cedlemo/blingbling"
+license=('GPL2')
+depends=('awesome'
+ 'lua-oocairo-git')
+makedepends=('git')
+provides=('blingbling')
+source=("git://github.com/cedlemo/blingbling.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd blingbling
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/awesome/lib/blingbling"
+ rm -r blingbling/{doc,config_example,.git*}
+ cp -a blingbling "$pkgdir/usr/share/awesome/lib/"
+}