summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Lopes2021-12-31 14:47:52 +0000
committerJose Lopes2021-12-31 14:47:52 +0000
commitefc6043170d1521f9b997840821b22505560d7ae (patch)
tree117766885fe819d1965bf419ea6921fefeebb864
parent038b894975e24314d68d9683867891465098b47f (diff)
downloadaur-efc6043170d1521f9b997840821b22505560d7ae.tar.gz
Add patch to fix build for python 3.10; Fix PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
-rw-r--r--fix_MutableSet.patch12
4 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c945043d467..a4e0a1aa342d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blink
pkgdesc = Fully featured, easy to use SIP client with a Qt based UI
pkgver = 5.1.8
- pkgrel = 1
+ pkgrel = 2
url = https://icanblink.com
arch = aarch64
arch = x86_64
@@ -20,6 +20,8 @@ pkgbase = blink
depends = qt5-webkit
optdepends = x11vnc: for screen sharing
source = blink-5.1.8.tar.gz::https://github.com/AGProjects/blink-qt/archive/a54013c11bee521a224c81c021e1bf453320ca79.tar.gz
+ source = fix_MutableSet.patch
b2sums = 7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878
+ b2sums = 1560c07c3ca8fecc1a47f793b06150cb3c4375a96f79e667202f13830d041cd318b024c6062e27e9a8f92c077b77a5095e0741a25b81a69378457959e1e4954d
pkgname = blink
diff --git a/.gitignore b/.gitignore
index 19b7361f8252..96b8d2e11375 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
*.log
*.tar.gz
-*.tar.xz
+*.tar.zst
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index af6c50d20b0e..0acbdcc0440f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=blink-qt
pkgname=blink
pkgver=5.1.8
-pkgrel=1
+pkgrel=2
pkgdesc='Fully featured, easy to use SIP client with a Qt based UI'
arch=('aarch64' 'x86_64')
url='https://icanblink.com'
@@ -25,8 +25,16 @@ depends=(
)
optdepends=('x11vnc: for screen sharing')
_commit=a54013c11bee521a224c81c021e1bf453320ca79 # 5.1.8
-source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/blink-qt/archive/$_commit.tar.gz")
-b2sums=('7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/$_commit.tar.gz" 'fix_MutableSet.patch')
+b2sums=(
+ '7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878'
+ '1560c07c3ca8fecc1a47f793b06150cb3c4375a96f79e667202f13830d041cd318b024c6062e27e9a8f92c077b77a5095e0741a25b81a69378457959e1e4954d'
+)
+
+prepare() {
+ cd $_pkgname-$_commit
+ patch --forward --strip=1 --input="${srcdir}/fix_MutableSet.patch"
+}
build() {
cd $_pkgname-$_commit
@@ -34,7 +42,7 @@ build() {
}
package() {
- cd _pkgname-$_commit
+ cd $_pkgname-$_commit
python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
# license
diff --git a/fix_MutableSet.patch b/fix_MutableSet.patch
new file mode 100644
index 000000000000..dcd1043ded9a
--- /dev/null
+++ b/fix_MutableSet.patch
@@ -0,0 +1,12 @@
+--- blink-git/blink/chatwindow.py.orig 2021-12-20 11:46:36.793749556 +0000
++++ blink-git/blink/chatwindow.py 2021-12-20 11:47:01.243794043 +0000
+@@ -18,7 +18,8 @@
+ from application.python.descriptor import WriteOnceAttribute
+ from application.python.types import MarkerType
+ from application.system import makedirs
+-from collections import MutableSet, deque
++from collections.abc import MutableSet
++from collections import deque
+ from datetime import datetime, timedelta
+ from itertools import count
+ from lxml import etree, html