summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Kugler2023-05-08 23:18:05 +0200
committerChristian Kugler2023-05-08 23:18:05 +0200
commit33733449102a2703c0d73853c3b83b5cdb8697fe (patch)
treeae1fa5c7091d2ab0dd27c6d4ef297c685af8cf30
parentd2a8dfe6d234132d4994d5f31d45ef1ab3916ac5 (diff)
downloadaur-blink1.tar.gz
Update version to 2.3.0 and the way the package is built
- To prevent the tag reference changing this uses the git rev-parse of the new version 2.3.0. This makes the build more stable. - Separate the submodule as a separate source for the build process. - Add back comments for former maintainers. - -Wno-format in the Makefile prevented building new version with default makepkg.conf. This removes this build option.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 267186627a70..ab0a81bd3bda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = blink1
pkgdesc = software for blink(1) USB RGB LED
- pkgver = 2.1.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/todbot/blink1-tool/
arch = i686
arch = x86_64
license = GPL
- source = git+https://github.com/todbot/blink1-tool.git#tag=v2.1.0
+ makedepends = git
+ conflicts = blink1-git
+ source = git+https://github.com/todbot/blink1-tool.git#tag=597db6b6a4954dbe9ff17a58b9bf6030bd6aaa89
+ source = git+https://github.com/libusb/hidapi.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = blink1
-
diff --git a/PKGBUILD b/PKGBUILD
index b91c437706f5..b393da55a829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
+# Maintainer: Christian Kugler <syphdias+git@gmail.com>
+# Contributor: Moritz Kaspar Rudert (mortzu)
+# Contributor: Christian Hesse <mail@eworm.de>
+
pkgname=blink1
-pkgver=2.1.0
+pkgver=2.3.0
+_tag=597db6b6a4954dbe9ff17a58b9bf6030bd6aaa89
pkgrel=1
pkgdesc='software for blink(1) USB RGB LED'
arch=('i686' 'x86_64')
url='https://github.com/todbot/blink1-tool/'
license=('GPL')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/todbot/blink1-tool/archive/v${pkgver}.tar.gz")
-source=("git+https://github.com/todbot/blink1-tool.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+makedepends=('git')
+conflicts=('blink1-git')
+source=("git+https://github.com/todbot/blink1-tool.git#tag=${_tag}"
+ 'git+https://github.com/libusb/hidapi.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
cd "${srcdir}/${pkgname}-tool"
git submodule init
- git submodule update
+
+ git config submodule.hidapi.url "${srcdir}/hidapi"
+
+ git -c protocol.file.allow=always submodule update
}
build() {
cd "${srcdir}/${pkgname}-tool"
+ # remove no-format, since it conflicts with format-security
+ sed -i 's/-Wno-format //' Makefile
make
}