summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Ott2019-07-31 03:11:15 +0200
committerStefan Ott2019-07-31 03:11:15 +0200
commitb4b06a0932fcbd22077678eddbef8fc69499fd46 (patch)
treeeb48853c5408216c761f4f6807656e84023c3776
downloadaur-b4b06a0932fcbd22077678eddbef8fc69499fd46.tar.gz
Initial import of blink1-python version 0.3.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2ea33233393
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blink1-python
+ pkgdesc = Official Python library for blink(1) USB RGB LED notification devices
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/todbot/blink1-python
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-webcolors
+ depends = python-hidapi
+ source = blink1-python-0.3.0.tar.gz::https://github.com/todbot/blink1-python/archive/0.3.0.tar.gz
+ sha512sums = 8b9bcb0c80f77b1a0346ac3974ee5f281fbb4ac481b95fe1dd363079c9fa15d9daf11034cd29820cdd4132e3816579d51c639a319be0e39a75bc28b00331085d
+
+pkgname = blink1-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8195a02fb48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Stefan Ott <stefan@ott.net>
+pkgname="blink1-python"
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Official Python library for blink(1) USB RGB LED notification devices"
+arch=("any")
+url="https://github.com/todbot/${pkgname}"
+license=("MIT")
+
+depends=("python" "python-webcolors" "python-hidapi")
+makedepends=("git" "python-setuptools")
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/todbot/blink1-python/archive/${pkgver}.tar.gz")
+sha512sums=("8b9bcb0c80f77b1a0346ac3974ee5f281fbb4ac481b95fe1dd363079c9fa15d9daf11034cd29820cdd4132e3816579d51c639a319be0e39a75bc28b00331085d")
+
+package()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}