summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Große Sundrup2024-03-25 00:26:00 -0400
committerJonas Große Sundrup2024-03-25 00:26:00 -0400
commit524058892605ef82dbc6061001e4f21806ecd6b1 (patch)
treedb4403b70bfce029900aafaf1ba30cc769d15082
parent337f4c4dc63cbd166d9d6c9c6c2f5892df4d5541 (diff)
downloadaur-524058892605ef82dbc6061001e4f21806ecd6b1.tar.gz
Package blinky 0.23.2 and migrate to new packaging guidelines
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db62fee6ec4a..fab7ab0a4e7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = blinky
pkgdesc = AUR-helper with minimal hassle
- pkgver = 0.23.1
+ pkgver = 0.23.2
pkgrel = 1
url = https://github.com/cherti/blinky
arch = any
license = GPLv3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = pyalpm
depends = python-requests
@@ -15,7 +18,7 @@ pkgbase = blinky
depends = wget
optdepends = libnotify
options = !emptydirs
- source = https://github.com/cherti/blinky/archive/v0.23.1.tar.gz
+ source = https://github.com/cherti/blinky/archive/v0.23.2.tar.gz
sha256sums = e9f617d9e704203ba8e755f90bd81f5efdb2572a8f868eb859fee21eec259dfd
pkgname = blinky
diff --git a/PKGBUILD b/PKGBUILD
index 14b8bd52d827..3ddcda560fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
# Maintainer: Jonas 'cherti' Große Sundrup <aur@letopolis.de>
pkgname=blinky
-pkgver=0.23.1
+pkgver=0.23.2
pkgrel=1
pkgdesc="AUR-helper with minimal hassle"
arch=(any)
url="https://github.com/cherti/blinky"
license=('GPLv3')
+makedepends=(python-build python-installer python-wheel)
depends=('python' 'pyalpm' 'python-requests' 'python-termcolor' 'python-pyxdg' 'python-packaging' 'colordiff' 'wget')
optdepends=('libnotify')
options=(!emptydirs)
-source=('https://github.com/cherti/blinky/archive/v0.23.1.tar.gz')
+source=('https://github.com/cherti/blinky/archive/v0.23.2.tar.gz')
sha256sums=('e9f617d9e704203ba8e755f90bd81f5efdb2572a8f868eb859fee21eec259dfd')
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 completion/_blinky "$pkgdir/usr/share/zsh/site-functions/_blinky"
+ install -Dm644 completion/_blinky "$pkgdir/usr/share/zsh/site-functions/_blinky"
}