summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12024-01-09 03:37:35 +0800
committerChocobo12024-01-09 03:39:17 +0800
commitbb4bf644c0a439894d29009219647453c406c457 (patch)
tree9885195aec6739d64d4b01065cab6afde67bce08
parent2a7e5a4d0acd0b35204964b937157fec588f4b4b (diff)
downloadaur-bb4bf644c0a439894d29009219647453c406c457.tar.gz
upgpkg: blis 0.9.0-3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD58
-rw-r--r--blis_profile.sh7
-rw-r--r--fpic.patch14
4 files changed, 38 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ce21d844c31..56c17f51cb94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = blis
- pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
+ pkgdesc = BLAS-like Library Instantiation Software Framework
pkgver = 0.9.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/flame/blis
+ arch = i686
arch = x86_64
- license = custom:BSD
- depends = glibc
+ license = custom
+ makedepends = python
+ depends = gcc-libs
provides = blas
+ provides = cblas
conflicts = blas
- options = !lto
- source = blis-0.9.0.tar.gz::https://github.com/flame/blis/archive/0.9.0.tar.gz
- source = fpic.patch
- source = blis_profile.sh
- sha512sums = 01e1990eefa4387839ac404089e4ffa32922ceaa30a1747c08a931c67706bcf29fed9d25e30c0faa36bba4f460821290e7973ed6b657d2cd95e126caaf853f81
- sha512sums = e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5
- sha512sums = cb53fa1f8c540062d4d55b4b91c787a821c563ea0bdb4e37f1db08869c320132a493e6b55f5d876418d56ad5b4f1dc5553f871862418393614e160dd1329ec9e
+ conflicts = cblas
+ options = staticlibs
+ source = blis-0.9.0-src.tar.gz::https://github.com/flame/blis/archive/refs/tags/0.9.0.tar.gz
+ sha256sums = 1135f664be7355427b91025075562805cdc6cc730d3173f83533b2c5dcc2f308
pkgname = blis
diff --git a/PKGBUILD b/PKGBUILD
index aaa81754b337..6b0d0323cd70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,40 @@
-# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=blis
pkgver=0.9.0
-pkgrel=2
-pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
-arch=('x86_64')
-license=('custom:BSD')
-depends=('glibc')
-url='https://github.com/flame/blis'
-options=('!makeflags' '!emptydirs')
-conflicts=('blas')
-provides=('blas')
-options=('!lto')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/flame/blis/archive/${pkgver}.tar.gz" fpic.patch blis_profile.sh)
-sha512sums=('01e1990eefa4387839ac404089e4ffa32922ceaa30a1747c08a931c67706bcf29fed9d25e30c0faa36bba4f460821290e7973ed6b657d2cd95e126caaf853f81'
- 'e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5'
- 'cb53fa1f8c540062d4d55b4b91c787a821c563ea0bdb4e37f1db08869c320132a493e6b55f5d876418d56ad5b4f1dc5553f871862418393614e160dd1329ec9e')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 < "$srcdir"/fpic.patch
-}
+pkgrel=3
+pkgdesc="BLAS-like Library Instantiation Software Framework"
+arch=('i686' 'x86_64')
+url="https://github.com/flame/blis"
+license=('custom')
+depends=('gcc-libs')
+makedepends=('python')
+provides=('blas' 'cblas')
+conflicts=('blas' 'cblas')
+options=('staticlibs')
+source=("$pkgname-$pkgver-src.tar.gz::https://github.com/flame/blis/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('1135f664be7355427b91025075562805cdc6cc730d3173f83533b2c5dcc2f308')
+
build() {
- cd $pkgname-$pkgver
- CFLAGS+=" -fPIC" ./configure -p "${pkgdir}"/usr auto
+ cd "$pkgname-$pkgver"
+
+ ./configure \
+ --prefix="/usr" \
+ --enable-cblas \
+ --enable-threading=openmp auto
make
}
check() {
- cd blis-${pkgver}/testsuite
- make
- ./test_libblis.x
+ cd "$pkgname-$pkgver"
+
+ #make check
}
package() {
- install -d "$pkgdir"/etc/profile.d
- cd $pkgname-$pkgver
- make install BLIS_ENABLE_DYNAMIC_BUILD:=yes
- install -Dm755 "$srcdir"/blis_profile.sh "${pkgdir}"/etc/profile.d/blis.sh
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/blis"
}
diff --git a/blis_profile.sh b/blis_profile.sh
deleted file mode 100644
index 66320296204d..000000000000
--- a/blis_profile.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-# Set blis loop threading environment variables
-# Please customize for your hardware and application
-
-export BLIS_IR_NT=1
-export BLIS_JR_NT=1
-export BLIS_IC_NT=1
-export BLIS_JC_NT=1
diff --git a/fpic.patch b/fpic.patch
deleted file mode 100644
index 58202e080dae..000000000000
--- a/fpic.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/config/x86_64/make_defs.mk b/config/x86_64/make_defs.mk
-index 2db7a8b8..30f41a62 100644
---- a/config/x86_64/make_defs.mk
-+++ b/config/x86_64/make_defs.mk
-@@ -52,7 +52,7 @@ endif
- # may specify additional flags here as needed.
- CPPROCFLAGS :=
- CMISCFLAGS :=
--CPICFLAGS :=
-+CPICFLAGS := -fPIC
- CWARNFLAGS :=
-
- ifneq ($(DEBUG_TYPE),off)
-