summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-02-24 20:43:04 +0100
committerhaawda2018-02-24 20:43:04 +0100
commitf049ecc4183ba2a822bf5d299f6d070d9a253436 (patch)
treea6a1f402ba00b5388e88d3457a90d683394cdb79
parent206d320ee01fda091d9bd8f428ec799b0827c918 (diff)
downloadaur-f049ecc4183ba2a822bf5d299f6d070d9a253436.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
-rw-r--r--fpic.patch14
3 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fbb1d4524dd..adf93e6665f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = blis
pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
- pkgver = 0.2.2
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/flame/blis
- arch = i686
arch = x86_64
- license = BSD
+ license = custom:BSD
depends = glibc
options = !makeflags
options = !emptydirs
- source = blis-0.2.2.tar.gz::https://github.com/flame/blis/archive/0.2.2.tar.gz
- sha512sums = f0981b6f33a56fc3f48a4570333899f30745f64928cf3599f9cd398d276c49d82f847fe73694cb3fd718ab42c8b3d48b606f63e7236ca9049f817456cac326e0
+ source = blis-0.3.0.tar.gz::https://github.com/flame/blis/archive/0.3.0.tar.gz
+ source = fpic.patch
+ sha512sums = cc78694bca8f2738b6d7c7b79c792486274157ee22c01c16d40efb9e4cd91a67abcca138cb6a0be9e1c9310cb7f645b9a00bb843fa9ce4e227e6d8e583c35daf
+ sha512sums = e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5
pkgname = blis
diff --git a/PKGBUILD b/PKGBUILD
index 870f6ab62d79..b066ba3c2c0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,33 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=blis
-pkgver=0.2.2
+pkgver=0.3.0
pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=('glibc')
-license=('BSD')
+license=('custom:BSD')
url='https://github.com/flame/blis'
#provides=('blas=3.5.0' 'cblas')
#conflicts=('blas' 'cblas')
options=('!makeflags' '!emptydirs')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/flame/blis/archive/${pkgver}.tar.gz")
-sha512sums=('f0981b6f33a56fc3f48a4570333899f30745f64928cf3599f9cd398d276c49d82f847fe73694cb3fd718ab42c8b3d48b606f63e7236ca9049f817456cac326e0')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/flame/blis/archive/${pkgver}.tar.gz" fpic.patch)
+sha512sums=('cc78694bca8f2738b6d7c7b79c792486274157ee22c01c16d40efb9e4cd91a67abcca138cb6a0be9e1c9310cb7f645b9a00bb843fa9ce4e227e6d8e583c35daf'
+ 'e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5')
prepare() {
-# Determine appropriate BLIS kernel for CPU
- cd "${srcdir}/blis-${pkgver}/build/auto-detect"
- _bliskernel="$(./auto-detect.sh)"
- echo "Selected a BLIS kernel for the ${_bliskernel} CPU architecture"
-
-# # Switch on BLAS compatibility and set Fortran name-mangling macros
-# sed -i '/#define BLIS_CONFIG_H/a#define BLIS_ENABLE_BLAS2BLIS\n#define BLIS_BLAS2BLIS_INT_TYPE_SIZE 32\n#define PASTEF770(name) name ## _ \n#define PASTEF77(ch1,name) ch1 ## name ## _ \n#define PASTEF772(ch1,ch2,name) ch1 ## ch2 ## name ## _' "${srcdir}//blis-${pkgver}/config/${_bliskernel}/bli_config.h"
-
-# # Switch on CBLAS compatibility (always switches on the BLAS compatibility layer)
-# sed -i '/#define PASTEF772(ch1,ch2,name) ch1 ## ch2 ## name ## _/a#define BLIS_ENABLE_CBLAS' "${srcdir}//blis-${pkgver}/config/${_bliskernel}/bli_config.h"
-
+ cd blis-${pkgver}
+ patch -Np1 < "$srcdir"/fpic.patch
}
build() {
- cd "${srcdir}/blis-${pkgver}"
- ./configure -p "${pkgdir}/usr" "${_bliskernel}"
+ cd blis-${pkgver}
+ CFLAGS+=" -fPIC" ./configure -p "${pkgdir}"/usr x86_64
make BLIS_ENABLE_DYNAMIC_BUILD:=yes
}
check() {
- cd "${srcdir}/blis-${pkgver}/testsuite"
+ cd blis-${pkgver}/testsuite
make
./test_libblis.x
}
diff --git a/fpic.patch b/fpic.patch
new file mode 100644
index 000000000000..58202e080dae
--- /dev/null
+++ b/fpic.patch
@@ -0,0 +1,14 @@
+diff --git a/config/x86_64/make_defs.mk b/config/x86_64/make_defs.mk
+index 2db7a8b8..30f41a62 100644
+--- a/config/x86_64/make_defs.mk
++++ b/config/x86_64/make_defs.mk
+@@ -52,7 +52,7 @@ endif
+ # may specify additional flags here as needed.
+ CPPROCFLAGS :=
+ CMISCFLAGS :=
+-CPICFLAGS :=
++CPICFLAGS := -fPIC
+ CWARNFLAGS :=
+
+ ifneq ($(DEBUG_TYPE),off)
+