summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-07-28 11:00:58 +0200
committerhaawda2018-07-28 11:00:58 +0200
commitf38a64e5f8da90c82beab7d8032d372e8fa569e7 (patch)
treeb67379e191c5db9b03e09378ef5fafa8f4bc493c
parent0e640db8807d5e32df1f823dc8fdddf55e2e1889 (diff)
downloadaur-f38a64e5f8da90c82beab7d8032d372e8fa569e7.tar.gz
update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c5d1119262f..9b7ffcd8505a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Mon Jul 2 18:20:50 UTC 2018
pkgbase = blis
pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
- pkgver = 0.3.2
- pkgrel = 2
+ pkgver = 0.4.0
+ pkgrel = 1
url = https://github.com/flame/blis
arch = x86_64
license = custom:BSD
options = !makeflags
options = !emptydirs
- source = blis-0.3.2.tar.gz::https://github.com/flame/blis/archive/0.3.2.tar.gz
+ source = blis-0.4.0.tar.gz::https://github.com/flame/blis/archive/0.4.0.tar.gz
source = fpic.patch
source = blis_profile.sh
- sha512sums = f7a0d495260e42d70520ffb71a28d4aaad3dd365cd5305964e9d8631b537aae84eb3f838ccc0d0f566c81d3ffbbd24c2b56ed653e5c42809e4b4a8e7c352c630
+ sha512sums = 05f8b6be110d7ab896c2172a4f1792f083c50742fe2839076c4216cda69e242b13f3a6682674f0e4a7308cbac6edec77a016a9e64e3d85d2bba02f3371e684aa
sha512sums = e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5
sha512sums = cb53fa1f8c540062d4d55b4b91c787a821c563ea0bdb4e37f1db08869c320132a493e6b55f5d876418d56ad5b4f1dc5553f871862418393614e160dd1329ec9e
diff --git a/PKGBUILD b/PKGBUILD
index fbb88b0118ff..484a7dea7d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=blis
-pkgver=0.3.2
-pkgrel=2
+pkgver=0.4.0
+pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
arch=('x86_64')
license=('custom:BSD')
url='https://github.com/flame/blis'
options=('!makeflags' '!emptydirs')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/flame/blis/archive/${pkgver}.tar.gz" fpic.patch blis_profile.sh)
-sha512sums=('f7a0d495260e42d70520ffb71a28d4aaad3dd365cd5305964e9d8631b537aae84eb3f838ccc0d0f566c81d3ffbbd24c2b56ed653e5c42809e4b4a8e7c352c630'
+sha512sums=('05f8b6be110d7ab896c2172a4f1792f083c50742fe2839076c4216cda69e242b13f3a6682674f0e4a7308cbac6edec77a016a9e64e3d85d2bba02f3371e684aa'
'e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5'
'cb53fa1f8c540062d4d55b4b91c787a821c563ea0bdb4e37f1db08869c320132a493e6b55f5d876418d56ad5b4f1dc5553f871862418393614e160dd1329ec9e')
@@ -22,7 +22,7 @@ prepare() {
build() {
cd $pkgname-$pkgver
CFLAGS+=" -fPIC" ./configure -p "${pkgdir}"/usr x86_64
- make BLIS_ENABLE_DYNAMIC_BUILD:=yes
+ make BLIS_ENABLE_DYNAMIC_BUILD:=yes
}
check() {
@@ -36,5 +36,5 @@ package() {
cd $pkgname-$pkgver
make install BLIS_ENABLE_DYNAMIC_BUILD:=yes
install -Dm755 "$srcdir"/blis_profile.sh "${pkgdir}"/etc/profile.d/blis.sh
- install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}