summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortuxzz2020-06-02 18:54:29 +0800
committertuxzz2020-06-02 18:54:29 +0800
commitcfe6d4b6b3115efb3a7d4a57d547532aa43ec0c1 (patch)
tree791f632320d69cd36ac3214aa1c913a4d285c72d
parentdbcee7c6a699a6a7dfb14801f779b8031e286eee (diff)
downloadaur-cfe6d4b6b3115efb3a7d4a57d547532aa43ec0c1.tar.gz
pkgrel 1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd3cbe4d9dcc..e416bb1e315d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blis-cblas-openmp
pkgdesc = BLAS-like Library Instantiation Software Framework (providing blas and cblas, with OpenMP support, particularly recommended for AMD Zen CPUs)
pkgver = 0.7.0
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/flame/blis
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2d78c6c5ffdf..fa543085bc17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=blis-cblas-openmp
pkgver=0.7.0
_blasver=3.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software Framework (providing blas and cblas, with OpenMP support, particularly recommended for AMD Zen CPUs)"
arch=('i686' 'x86_64')
license=('custom')
@@ -36,6 +36,16 @@ build() {
export CFLAGS="-pipe -Ofast -fno-plt -ftree-vectorize -flto -falign-functions=32 -fno-semantic-interposition -fipa-pta -fdevirtualize-at-ltrans -floop-nest-optimize -floop-strip-mine -floop-interchange -fgraphite-identity"
export CXXFALGS=${CFLAGS}
+ export BLIS_JC_NT=1
+ export BLIS_PC_NT=1
+ export BLIS_IC_NT=1
+ export BLIS_JR_NT=1
+ export BLIS_IR_NT=1
+ export OMP_NUM_THREADS=1
+ export OPENBLAS_NUM_THREADS=1
+ export MKL_NUM_THREADS=1
+ export nt_use=1
+
# static build is necessary for some packages and programs (e. g. GAMESS)
./configure --prefix=/usr --enable-static --enable-shared --enable-cblas --enable-threading=openmp auto
make
@@ -43,6 +53,16 @@ build() {
check() {
cd "${pkgname}"
+
+ export BLIS_JC_NT=1
+ export BLIS_PC_NT=1
+ export BLIS_IC_NT=1
+ export BLIS_JR_NT=1
+ export BLIS_IR_NT=1
+ export OMP_NUM_THREADS=1
+ export OPENBLAS_NUM_THREADS=1
+ export MKL_NUM_THREADS=1
+ export nt_use=1
make check
}