summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-05-29 15:59:22 +0200
committerhaawda2017-05-29 15:59:22 +0200
commit5c7d36b9f98a58bb14c574e09340d3d52c15e2a6 (patch)
treee08482da456b5e76738856459a012f0c8839ecb3
downloadaur-5c7d36b9f98a58bb14c574e09340d3d52c15e2a6.tar.gz
initial upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..119d7a712577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blis-git
+ pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
+ pkgver = 0.2.1.126.g6e04f9df
+ pkgrel = 1
+ url = https://github.com/flame/blis
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ options = !makeflags
+ options = !emptydirs
+ source = git+https://github.com/flame/blis.git
+ md5sums = SKIP
+
+pkgname = blis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..559d1e00ccf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=blis-git
+pkgver=0.2.1.126.g6e04f9df
+pkgrel=1
+pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('glibc')
+url='https://github.com/flame/blis'
+#provides=('blas=3.5.0' 'cblas')
+#conflicts=('blas' 'cblas')
+options=('!makeflags' '!emptydirs')
+source=("git+https://github.com/flame/blis.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "%s" $(git describe --tags|tr - .)
+}
+
+prepare() {
+# Determine appropriate BLIS kernel for CPU
+ cd "${pkgname%-git}/build/auto-detect"
+ _bliskernel="$(./auto-detect.sh)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ ./configure -p "${pkgdir}/usr" "${_bliskernel}"
+ make BLIS_ENABLE_DYNAMIC_BUILD:=yes
+}
+
+check() {
+ cd "${pkgname%-git}"/testsuite
+ make
+ ./test_libblis.x
+}
+
+package() {
+ mkdir -p "${pkgdir}/etc/profile.d"
+ cd "${pkgname%-git}"
+ make install BLIS_ENABLE_DYNAMIC_BUILD:=yes
+# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libblas.so"
+# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libcblas.so"
+ printf "# Set blis loop threading environment variables\\n# Please customize for your hardware and application\\n\\nexport BLIS_IR_NT=1\\nexport BLIS_JR_NT=1\\nexport BLIS_IC_NT=1\\nexport BLIS_JC_NT=1" > "${pkgdir}/etc/profile.d/blis.sh"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}