summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-12-18 00:35:17 +0100
committerhaawda2017-12-18 00:35:17 +0100
commit9d5f5dfe16e1135b5bb7d10eb9e57d8214a94067 (patch)
tree47e82ab69f70be95b000c9454806b021982da2b5
parent7eced7b23504c21c88bad7b6904946b5ed0896b3 (diff)
downloadaur-9d5f5dfe16e1135b5bb7d10eb9e57d8214a94067.tar.gz
prepare flatten-headers.py for use with python2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d02b2e9e4eb..4b7caf3f8ed6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 19:24:20 UTC 2017
+# Sun Dec 17 23:35:17 UTC 2017
pkgbase = blis-git
pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
- pkgver = 0.2.2.123.ga32e8a47
+ pkgver = 0.2.2.124.g99dee87f
pkgrel = 1
url = https://github.com/flame/blis
arch = i686
arch = x86_64
license = BSD
+ makedepends = python2
depends = glibc
options = !makeflags
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index d437a3cb68a2..c2e7df4db7b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=blis-git
-pkgver=0.2.2.123.ga32e8a47
+pkgver=0.2.2.124.g99dee87f
pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
arch=('i686' 'x86_64')
license=('BSD')
depends=('glibc')
+makedepends=('python2')
url='https://github.com/flame/blis'
#provides=('blas=3.5.0' 'cblas')
#conflicts=('blas' 'cblas')
@@ -24,19 +25,21 @@ prepare() {
# Determine appropriate BLIS kernel for CPU
cd "${pkgname%-git}/build/auto-detect"
_bliskernel="$(./auto-detect.sh)"
+ cd ..
+ sed -i '1s+python$+python2+' flatten-headers.py
}
build() {
cd "${pkgname%-git}"
./configure -p "${pkgdir}/usr" "${_bliskernel}"
- make BLIS_ENABLE_DYNAMIC_BUILD:=yes
+ make BLIS_ENABLE_DYNAMIC_BUILD:=yes
}
-#check() {
-# cd "${pkgname%-git}"/testsuite
-# make
-# ./test_libblis.x
-#}
+check() {
+ cd "${pkgname%-git}"/testsuite
+ make
+ ./test_libblis.x
+}
package() {
mkdir -p "${pkgdir}/etc/profile.d"