summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Buske2024-11-18 20:28:25 -0400
committerBenjamin Buske2024-11-18 20:28:25 -0400
commitae21d0556019e392a4dfa5fe5197e913b0ef9030 (patch)
tree5754b017071b4353908f2610fd10ec7527710f74
downloadaur-ae21d0556019e392a4dfa5fe5197e913b0ef9030.tar.gz
Initial commit of Blisk.io Web Browser, especially made for developers.
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD21
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a76650509b85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = blisk-browser-stable
+ pkgdesc = The browser from blisk.io. Blisk is the first developer-oriented browser. It provides teams and freelancers with a workspace to develop and test modern web applications at least twice faster.
+ pkgver = 23.0.185.91
+ pkgrel = 1
+ url = https://blisk.io
+ arch = i686
+ arch = x86_64
+ depends = alsa-lib
+ depends = at-spi2-core
+ depends = bash-completion
+ depends = ca-certificates
+ depends = cairo>=1.6.0
+ depends = curl
+ depends = dbus>=1.9.14
+ depends = desktop-file-utils
+ depends = expat>=2.1beta3
+ depends = gcc-libs
+ depends = glib2>=2.39.4
+ depends = glibc>=2.17
+ depends = gtk3
+ depends = gtk4
+ depends = hicolor-icon-theme
+ depends = libcups>=1.6.0
+ depends = libcurl-gnutls
+ depends = libdrm>=2.4.75
+ depends = libx11>=1.4.99.1
+ depends = libxcb>=1.9.2
+ depends = libxcomposite>=0.4.4
+ depends = libxdamage>=1.1
+ depends = libxext
+ depends = libxfixes
+ depends = libxrandr
+ depends = mesa>=17.1.0rc2
+ depends = nspr>=4.9
+ depends = nss>=3.35
+ depends = pango
+ depends = ttf-liberation
+ depends = xdg-utils>=1.0.2
+ provides = blisk-browser-stable
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://blisk.io/download/installer/?os=linux-rpm
+ sha512sums_x86_64 = SKIP
+
+pkgname = blisk-browser-stable
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f07c7b3ccf34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Benjamin Buske (info@buske-it.com)
+# Contributor: Benjamin Buske (info@buske-it.com)
+pkgname=blisk-browser-stable
+pkgver=23.0.185.91
+pkgrel=1
+pkgdesc="The browser from blisk.io. Blisk is the first developer-oriented browser. It provides teams and freelancers with a workspace to develop and test modern web applications at least twice faster."
+arch=('i686' 'x86_64')
+url="https://blisk.io"
+depends=('alsa-lib' 'at-spi2-core' 'bash-completion' 'ca-certificates' 'cairo>=1.6.0' 'curl' 'dbus>=1.9.14' 'desktop-file-utils' 'expat>=2.1beta3' 'gcc-libs' 'glib2>=2.39.4' 'glibc>=2.17' 'gtk3' 'gtk4' 'hicolor-icon-theme' 'libcups>=1.6.0' 'libcurl-gnutls' 'libdrm>=2.4.75' 'libx11>=1.4.99.1' 'libxcb>=1.9.2' 'libxcomposite>=0.4.4' 'libxdamage>=1.1' 'libxext' 'libxfixes' 'libxrandr' 'mesa>=17.1.0rc2' 'nspr>=4.9' 'nss>=3.35' 'pango' 'ttf-liberation' 'xdg-utils>=1.0.2')
+provides=('blisk-browser-stable')
+options=('!strip' '!emptydirs')
+source_x86_64=("https://blisk.io/download/installer/?os=linux-rpm")
+
+sha512sums_x86_64=('SKIP')
+
+package(){
+
+ # Extract package data
+ find $srcdir/ -mindepth 1 -maxdepth 1 -type d | xargs cp -r -t "$pkgdir"
+
+}