summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-03-25 04:36:49 +0000
committerPellegrino Prevete2022-03-25 04:36:49 +0000
commit68edcb22cceca509f48d14f12e2ebeb333a85b91 (patch)
tree7c8eb6f10f8a1e9eac147dbe20ef7b58448f497d
parenta8d80006523033e81a4d66cdd1e71e6475ebfc8c (diff)
downloadaur-68edcb22cceca509f48d14f12e2ebeb333a85b91.tar.gz
Move to git fetched package; added git makedep
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e5c13b844b9..d857c2ecdd16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = blivet-gui
url = https://github.com/storaged-project/blivet-gui
arch = any
license = GPL
+ makedepends = git
makedepends = make
depends = python
depends = python-blivet
@@ -12,7 +13,7 @@ pkgbase = blivet-gui
depends = python-gobject
depends = python-pid
depends = adwaita-icon-theme
- source = blivet-gui-2.3.0.tar.gz::http://github.com/storaged-project/blivet-gui/archive/2.3.0.tar.gz
- sha512sums = cf13480e076355e340198d83ea77b04338803e8fb1a5d2a942ae7754f28c5e6e48cbadef500ff053e2c3a0b795c8a0f4757c1da5e728f557ae7f551a0d6f5746
+ source = blivet-gui::git+https://github.com/storaged-project/blivet-gui#tag=2.3.0-1
+ sha512sums = SKIP
pkgname = blivet-gui
diff --git a/PKGBUILD b/PKGBUILD
index 4a31ec5e9d72..850e3d6f1e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Julian Mac Kenzie <jukiangm@gmail.com>
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Julian Mac Kenzie <jukiangm@gmail.com>
+# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=blivet-gui
-_realver=2.3.0
-_tag="${_realver}"
-pkgver=${_realver/-/.}
+pkgver=2.3.0
+_pkgver="${pkgver}-1"
pkgrel=1
pkgdesc='GUI tool for storage configuration'
arch=('any')
license=('GPL')
url='https://github.com/storaged-project/blivet-gui'
depends=('python' 'python-blivet' 'python-cairo' 'python-gobject' 'python-pid' 'adwaita-icon-theme')
-makedepends=('make')
-source=("${pkgname}-${pkgver}.tar.gz::http://github.com/storaged-project/blivet-gui/archive/${_tag}.tar.gz")
-sha512sums=('cf13480e076355e340198d83ea77b04338803e8fb1a5d2a942ae7754f28c5e6e48cbadef500ff053e2c3a0b795c8a0f4757c1da5e728f557ae7f551a0d6f5746')
+makedepends=('git' 'make')
+source=("${pkgname}::git+${url}#tag=${_pkgver}")
+sha512sums=('SKIP')
build() {
- cd "${srcdir}/${pkgname}-${_tag}"
+ cd "${pkgname}"
make
}
package() {
- cd "${srcdir}/${pkgname}-${_tag}"
-
- echo "${pkgdir}"
+ cd "${pkgname}"
make DESTDIR="${pkgdir}" RPM_BUILD_ROOT="${pkgdir}" install
}