summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 12:01:12 +0800
committerzxp198210052024-03-22 12:01:12 +0800
commitb1295048354ad1d91f6945939ff87d8170044d3d (patch)
treee08583f56c54925a6649d0643671c85268e45729
parent3eb1b284df7d4ac09dd482c2661a1dadecdd2df2 (diff)
downloadaur-b1295048354ad1d91f6945939ff87d8170044d3d.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--blix.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75950c914503..7c453f99c0d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = blix-bin
pkgdesc = A cross-platform AI-assisted graph photo editor.
pkgver = 1.3.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/COS301-SE-2023/AI-Photo-Editor
arch = aarch64
arch = x86_64
license = GPL-3.0-only
makedepends = asar
- depends = electron24
+ depends = electron24-bin
provides = blix=1.3.0
conflicts = blix
options = !strip
source = blix.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = blix-1.3.0-aarch64.deb::https://github.com/COS301-SE-2023/AI-Photo-Editor/releases/download/v1.3.0/blix_1.3.0_arm64.deb
sha256sums_aarch64 = d1444cb7ed34ead088218271eebb6b02868a3a881fb400a14e21fe22b33f6f43
source_x86_64 = blix-1.3.0-x86_64.deb::https://github.com/COS301-SE-2023/AI-Photo-Editor/releases/download/v1.3.0/blix_1.3.0_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index c4a594607dfb..5628a7e38910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=blix-bin
_pkgname=Blix
pkgver=1.3.0
_electronversion=24
-pkgrel=5
+pkgrel=6
pkgdesc="A cross-platform AI-assisted graph photo editor."
arch=(
'aarch64'
@@ -15,7 +15,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
options=('!strip')
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
)
makedepends=(
'asar'
@@ -23,13 +23,14 @@ makedepends=(
source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('d1444cb7ed34ead088218271eebb6b02868a3a881fb400a14e21fe22b33f6f43')
sha256sums_x86_64=('cc3356aede7d58bfcc2758d700f6bd836181bc87566491b573f4bb4f031bab4f')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g;s|productivity|Graphics|g" \
diff --git a/blix.sh b/blix.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/blix.sh
+++ b/blix.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file