summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYamakaky2016-11-11 18:03:39 -0500
committerYamakaky2016-11-11 18:03:39 -0500
commit224c58eb5142715277fcd3c512c377a6cba86d15 (patch)
tree29d37ec99932e21146bf8a46a17e5f587f5c108e
downloadaur-224c58eb5142715277fcd3c512c377a6cba86d15.tar.gz
First version
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b33005b5ff65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bloaty-git
+ pkgdesc = A size profiler for binaries
+ pkgver = 0.0.0.r68.g263f2ef
+ pkgrel = 1
+ url = https://github.com/google/bloaty
+ arch = x86_64
+ arch = x86
+ license = Apache v2.0
+ makedepends = git
+ makedepends = gcc
+ source = git+https://github.com/google/bloaty
+ md5sums = SKIP
+
+pkgname = bloaty-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..81e80b0c5b03
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar
+src/
+pkg/
+/bloaty/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7809833916b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yamakaky <yamakaky@yamaworld.fr>
+pkgname=bloaty-git
+pkgver=0.0.0.r68.g263f2ef
+pkgrel=1
+pkgdesc="A size profiler for binaries"
+arch=("x86_64" "x86")
+url="https://github.com/google/bloaty"
+license=("Apache v2.0")
+makedepends=("git" "gcc")
+source=("git+https://github.com/google/bloaty")
+md5sums=("SKIP")
+
+pkgver() {
+ cd bloaty
+ printf "0.0.0.r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/bloaty"
+ make
+}
+
+package() {
+ install -D "$srcdir/bloaty/bloaty" "$pkgdir/usr/bin/bloaty"
+}