summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2022-05-10 08:38:38 +0000
committerFelix Yan2022-05-10 08:38:38 +0000
commit01e55ee9ea9fa1c710281c1c5012920e886a8512 (patch)
tree3a1c216e19545035ec97d867701d4bb12f98873d
parentab7201c256b3a544821048de8dfb84907be68daa (diff)
downloadaur-01e55ee9ea9fa1c710281c1c5012920e886a8512.tar.gz
upgpkg: 3.0.0-1
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da946528baca..a81dc70b7cca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: David Runge <dvzrv@archlinux.org>
pkgname=blockdiag
-pkgver=2.0.1
-pkgrel=6
+pkgver=3.0.0
+pkgrel=1
pkgdesc="blockdiag generates block-diagram image from text"
url="http://blockdiag.com"
license=('Apache')
@@ -14,7 +14,7 @@ checkdepends=('python-nose' 'python-mock' 'python-pycodestyle' 'python-reportlab
optdepends=('python-reportlab: for PDF export'
'python-docutils: for RST parser')
source=("$pkgname-$pkgver.tar.gz::https://github.com/blockdiag/blockdiag/archive/$pkgver.tar.gz")
-sha512sums=('509535312bd46022203d279604507e09106680722d98516dabd7187bc48d9a195709f2534f2f7757058c06b914b517ec2f6d899cec12e7df24ba4ab28ec76bcd')
+sha512sums=('9eb5aa0d78dd546feafccdf66dbedbc8b8addb97ffa45f18396bfb8e144be3acfaa4493baf680922af87ff64194424b7378367f177b1a59c3b3898b5c235623c')
build() {
cd blockdiag-$pkgver
@@ -25,8 +25,8 @@ check() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd blockdiag-$pkgver
python setup.py install --root="$PWD/tmp_install" --optimize=1
- # TODO: figure out the failure
- PYTHONPATH="$PWD/tmp_install/${site_packages}" nosetests -v -e "test_setup_inline_svg_is_true_with_multibytes"
+ # https://github.com/blockdiag/blockdiag/issues/165
+ PYTHONPATH="$PWD/tmp_install/${site_packages}" nosetests -v -e "svg_sanitizes_url_on_error_test"
}
package() {