summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2020-09-26 09:39:49 +0000
committerDavid Runge2020-09-26 09:39:49 +0000
commit999759149530ee8900c4b9bfa57709cfeeaf8288 (patch)
treecbb14d2113a0598e72a0836f28071c66adc3e70d
parent39b423e51a2afad1d6b7fca2f42f5254d99ac34a (diff)
downloadaur-999759149530ee8900c4b9bfa57709cfeeaf8288.tar.gz
Rebuild to add files and optdepends.
Add python-reportlab and python-docutils to optdepends. Add docs. Add man page. Do not build in package(). Replace hardcoded site-packages dir with generically retrieved location. Add contributor information.
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82128250ad09..992d6342f653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: David Runge <dvzrv@archlinux.org>
pkgname=blockdiag
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="blockdiag generates block-diagram image from text"
url="http://blockdiag.com"
license=('Apache')
@@ -10,6 +11,8 @@ arch=('any')
depends=('python-setuptools' 'python-funcparserlib' 'python-pillow' 'python-webcolors')
checkdepends=('python-nose' 'python-mock' 'python-pycodestyle' 'python-reportlab' 'python-docutils'
'python-wand' 'ghostscript' 'librsvg')
+optdepends=('python-reportlab: for PDF export'
+ 'python-docutils: for RST parser')
source=("$pkgname-$pkgver.tar.gz::https://github.com/blockdiag/blockdiag/archive/$pkgver.tar.gz")
sha512sums=('509535312bd46022203d279604507e09106680722d98516dabd7187bc48d9a195709f2534f2f7757058c06b914b517ec2f6d899cec12e7df24ba4ab28ec76bcd')
@@ -19,13 +22,18 @@ build() {
}
check() {
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd blockdiag-$pkgver
python setup.py install --root="$PWD/tmp_install" --optimize=1
# TODO: figure out the failure
- PYTHONPATH="$PWD/tmp_install/usr/lib/python3.8/site-packages" nosetests -e "test_setup_inline_svg_is_true_with_multibytes"
+ PYTHONPATH="$PWD/tmp_install/${site_packages}" nosetests -v -e "test_setup_inline_svg_is_true_with_multibytes"
}
package() {
cd blockdiag-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" \
+ --optimize=1 \
+ --skip-build
+ install -vDm 644 {CHANGES,README}.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -vDm 644 "${pkgname}.1" -t "${pkgdir}/usr/share/man/man1/"
}