summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbl00dy18372021-06-13 15:52:07 +0200
committerbl00dy18372021-06-13 15:52:07 +0200
commit4102204d2240e4cf9a868816a5916d3b28900867 (patch)
tree40cc0afa9e4c33a606d73c4d777c62ecb56d2c10
parent9146a6b2cc62ac7a4e5d2bcb0af98406cda196bf (diff)
downloadaur-4102204d2240e4cf9a868816a5916d3b28900867.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 43 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2630978476c2..35472120c5b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
-# Generated by mksrcinfo v8
-# Thu Dec 24 22:29:21 UTC 2015
pkgbase = blockout2
- pkgdesc = 3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989
+ pkgdesc = 3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989. Pre-compiled.
pkgver = 2.5
- pkgrel = 3
+ pkgrel = 1
url = http://www.blockout.net/blockout2/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
depends = libgl
depends = glu
depends = libxext
depends = sdl
depends = sdl_mixer
+ conflicts = blockout2-bin
+ source = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-src.tar.gz
+ source = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz
source = blockout2
source = blockout2.desktop
source = blockout2.png
+ md5sums = c68a6d6f1f42aa61dbce84b100f19351
+ md5sums = 6155d0596d762852e3fbd1718d3d6455
md5sums = 130e2c10b68b41bf12e67a764a2ea4fb
md5sums = c3d7d196e4af7fabd287376988376fe4
md5sums = 166642ab949cd145f6126857a5ac7e4f
- source_i686 = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x86.tar.gz
- md5sums_i686 = 6e29242d76cd5bbf8caee62127f02e19
- source_x86_64 = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz
- md5sums_x86_64 = 6155d0596d762852e3fbd1718d3d6455
pkgname = blockout2
-
diff --git a/PKGBUILD b/PKGBUILD
index 2dac666a108b..37efcbb6f7e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,44 @@
-# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
-# Contributor: Piotr Beling <qwak [at] stud.ics.p.lodz.pl>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor:: pezcurrel <pezcurrel [at] tiscali.it>
pkgname=blockout2
pkgver=2.5
-pkgrel=3
-pkgdesc="3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989"
-arch=("i686" "x86_64")
+pkgrel=1
+pkgdesc="3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989. Pre-compiled."
+arch=("any")
url="http://www.blockout.net/blockout2/"
depends=("libgl" "glu" "libxext" "sdl" "sdl_mixer")
license=("GPL")
-source_x86_64=("http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz")
-source_i686=("http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x86.tar.gz")
-source=("blockout2" "blockout2.desktop" "blockout2.png")
-md5sums_x86_64=("6155d0596d762852e3fbd1718d3d6455")
-md5sums_i686=("6e29242d76cd5bbf8caee62127f02e19")
-md5sums=("130e2c10b68b41bf12e67a764a2ea4fb"
- "c3d7d196e4af7fabd287376988376fe4"
- "166642ab949cd145f6126857a5ac7e4f")
+conflicts=("blockout2-bin")
+source=(
+ "http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-src.tar.gz"
+ "http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz"
+ "blockout2"
+ "blockout2.desktop"
+ "blockout2.png"
+)
+md5sums=(
+ "c68a6d6f1f42aa61dbce84b100f19351"
+ "6155d0596d762852e3fbd1718d3d6455"
+ "130e2c10b68b41bf12e67a764a2ea4fb"
+ "c3d7d196e4af7fabd287376988376fe4"
+ "166642ab949cd145f6126857a5ac7e4f"
+)
+
+build () {
+ cd "${srcdir}/BL_SRC/ImageLib/src/"
+ make
+ cd "${srcdir}/BL_SRC/BlockOut/"
+ make
+}
package() {
- install -d "$pkgdir"/{opt,usr/bin,usr/share/applications,usr/share/pixmaps}
- chmod -x "$srcdir"/blockout/README.txt "$srcdir"/blockout/images/background.png "$srcdir"/blockout/sounds/music.ogg
- mv "$srcdir"/blockout "$pkgdir"/opt/blockout2
- cp -L "$srcdir"/blockout2 "$pkgdir"/usr/bin/
- cp -L blockout2.desktop "$pkgdir"/usr/share/applications/
- cp -L blockout2.png "$pkgdir"/usr/share/pixmaps/
+ install -d "${pkgdir}"/{opt/blockout2,usr/bin,usr/share/applications,usr/share/pixmaps}
+ chmod -x "${srcdir}/blockout/images/background.png" "$srcdir"/blockout/sounds/music.ogg
+ mv "${srcdir}/BL_SRC/BlockOut/blockout" "${pkgdir}/opt/blockout2/"
+ mv "${srcdir}/blockout/sounds" "${pkgdir}/opt/blockout2/"
+ mv "${srcdir}/blockout/images" "${pkgdir}/opt/blockout2/"
+ cp "${srcdir}/blockout2" "${pkgdir}/usr/bin/"
+ cp "blockout2.desktop" "${pkgdir}/usr/share/applications/"
+ cp "blockout2.png" "${pkgdir}/usr/share/pixmaps/"
}