summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-05-08 09:59:49 +0800
committerzxp198210052024-05-08 09:59:49 +0800
commit3bf45915844a544c89a6f48088d88b33155d0a32 (patch)
tree1fcbe6544d4b4829d33bab2e27c368dc23c426f8
parent196e1ac275bba54e5522d0c0602c8ea884b1612c (diff)
downloadaur-3bf45915844a544c89a6f48088d88b33155d0a32.tar.gz
update to 3.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--blockyfish-client.sh19
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d2f0532d3f3..678be6e74ba8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = blockyfish-client-bin
pkgdesc = A custom desktop client for deeeep.io v4 with some improvements. Made by pi.
- pkgver = 3.2.0
+ pkgver = 3.2.1
pkgrel = 1
url = https://blockyfish.vercel.app/
arch = x86_64
license = GPL-3.0-only
depends = electron30
- provides = blockyfish-client=3.2.0
+ provides = blockyfish-client=3.2.1
conflicts = blockyfish-client
options = !emptydirs
- source = blockyfish-client-3.2.0.tar.xz::https://github.com/blockyfish-client/desktop-client/releases/download/v3.2.0/blockyfish-client-linux-3.2.0.tar.xz
- source = blockyfish-client-3.2.0.png::https://raw.githubusercontent.com/blockyfish-client/desktop-client/v3.2.0/src/icons/256x256.png
+ source = blockyfish-client-3.2.1.tar.xz::https://github.com/blockyfish-client/desktop-client/releases/download/v3.2.1/blockyfish-client-linux-3.2.1.tar.xz
+ source = blockyfish-client-3.2.1.png::https://raw.githubusercontent.com/blockyfish-client/desktop-client/v3.2.1/src/icons/256x256.png
source = blockyfish-client.desktop
source = blockyfish-client.sh
- sha256sums = 7b9faa25228e1105e893442d14a3696c2814f3265ca4bd9f3096e8906fcf98c2
+ sha256sums = 17abae81f7d10fd18d447ebebfa8377afc15abd3739c7f5c2b70e9bfe9a71a81
sha256sums = a12cbee4d98a5ce986a40d133219d735433edd94d858fc86babe0868e5e87145
sha256sums = faa003033e5b2e0b9728cc4ac93eefd26a223a8cd1c6788eb1912e3537cf2765
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a
pkgname = blockyfish-client-bin
diff --git a/PKGBUILD b/PKGBUILD
index 45f49f233dc0..0c2b9b74d215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=blockyfish-client-bin
_pkgname="Blockyfish Client"
-pkgver=3.2.0
+pkgver=3.2.1
_electronversion=30
pkgrel=1
pkgdesc="A custom desktop client for deeeep.io v4 with some improvements. Made by pi."
@@ -23,14 +23,14 @@ source=(
"${pkgname%-bin}.desktop"
"${pkgname%-bin}.sh"
)
-sha256sums=('7b9faa25228e1105e893442d14a3696c2814f3265ca4bd9f3096e8906fcf98c2'
+sha256sums=('17abae81f7d10fd18d447ebebfa8377afc15abd3739c7f5c2b70e9bfe9a71a81'
'a12cbee4d98a5ce986a40d133219d735433edd94d858fc86babe0868e5e87145'
'faa003033e5b2e0b9728cc4ac93eefd26a223a8cd1c6788eb1912e3537cf2765'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@runname@|app|g" \
+ -e "s|@runname@|app.asar|g" \
-e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
}
diff --git a/blockyfish-client.sh b/blockyfish-client.sh
index 7ddcaab8d734..5594e5380ba2 100644
--- a/blockyfish-client.sh
+++ b/blockyfish-client.sh
@@ -7,10 +7,23 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+declare -a flags
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ mapfile -t < "${_FLAGS_FILE}"
+fi
+for line in "${MAPFILE[@]}"; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
+ flags+=("${line}")
+ fi
+done
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file