summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuri Grabowski2015-09-20 18:33:07 +0200
committerJuri Grabowski2015-09-20 18:33:07 +0200
commit9439c6f9ad0e287c87eae088cb1b6b7ceb3ae5be (patch)
tree1615533bcd08393141e84bbe8eb448b7903e3fa4
downloadaur-9439c6f9ad0e287c87eae088cb1b6b7ceb3ae5be.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..985f829bd367
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = blogc
+ pkgver = 0.1
+ pkgrel = 0
+ url = http://blogc.org
+ arch = any
+ license = GPL
+ options = !emptydirs
+ source = https://github.com/blogc/blogc/releases/download/v0.1/blogc-0.1.tar.gz
+ md5sums = c7156ea14591fdf01c45e969792cfc73
+
+pkgname = blogc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ed48f1c44fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 216470 2014-07-04 04:21:35Z fyan $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Hunt <lazy at brandnewmath dot com>
+
+pkgname=blogc
+pkgver=0.1
+pkgrel=0
+pkgdesc="blogc is a blog compiler. It converts source files and templates into blog/website resources"
+arch=('any')
+url="http://blogc.org"
+license=('BSD 3 clause license')
+depends=()
+options=('!emptydirs')
+source=("https://github.com/blogc/blogc/releases/download/v0.1/blogc-0.1.tar.gz")
+md5sums=('c7156ea14591fdf01c45e969792cfc73')
+
+
+build() {
+ cd $srcdir/blogc-$pkgver
+ ./autogen.sh
+ ./configure --prefix=/usr/
+ make
+}
+
+package() {
+ cd $srcdir/blogc-$pkgver
+ make install DESTDIR=$pkgdir
+}