summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2021-08-15 19:07:40 -0400
committerGI_Jack2021-08-15 19:07:40 -0400
commit29072ac946d74875f1003290cdd2dcea5aa619dd (patch)
treee45e3bdb6679ab319dc6520929acffbb93bb6ec0
downloadaur-29072ac946d74875f1003290cdd2dcea5aa619dd.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD63
-rw-r--r--bloodhound.desktop12
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c17df6be624
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Sun Aug 15 07:07:25 PM EDT 2021
+pkgbase = bloodhound
+ pkgdesc = Use graph theory to reveal the hidden and often unintended relationships within an Active Directory
+ pkgver = 4.0.3
+ pkgrel = 1
+ url = https://github.com/BloodHoundAD/BloodHound
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = GPLv3
+ makedepends = electron
+ makedepends = npm
+ makedepends = python-sphinx
+ depends = neo4j-community
+ depends = java-runtime
+ source = https://github.com/BloodHoundAD/BloodHound/archive/4.0.3.tar.gz
+ source = bloodhound.desktop
+ sha256sums = 5908676e3e6679381231720fdf494c6b73f096ce7cd47378671603d9699fe9f5
+ sha256sums = 8a64de7e9fc4857fadd890cc8966a641a896077eb2c869a7eb0987074dcd02c2
+
+pkgname = bloodhound
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05ca3c79517e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+
+pkgname=bloodhound
+_pkgname=BloodHound
+pkgver=4.0.3
+pkgrel=1
+pkgdesc="Use graph theory to reveal the hidden and often unintended relationships within an Active Directory"
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/BloodHoundAD/BloodHound"
+license=('GPLv3')
+depends=('neo4j-community' 'java-runtime')
+makedepends=('electron' 'npm' 'python-sphinx' )
+source=("https://github.com/BloodHoundAD/BloodHound/archive/${pkgver}.tar.gz"
+ "bloodhound.desktop")
+sha256sums=('5908676e3e6679381231720fdf494c6b73f096ce7cd47378671603d9699fe9f5'
+ '8a64de7e9fc4857fadd890cc8966a641a896077eb2c869a7eb0987074dcd02c2')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ HOME="$srcdir/.electron-gyp" npm install
+ HOME="$srcdir/.electron-gyp" npm run linuxbuild
+ # Documentation
+ cd docs
+ make man html
+ cd ..
+}
+
+package() {
+ # Desktop file
+ install -Dm644 bloodhound.desktop "${pkgdir}/usr/share/applications/bloodhound.desktop"
+
+ cd "${_pkgname}-${pkgver}"
+
+ # The App
+ install -d "${pkgdir}/opt/${pkgname}/"
+ if [ "${CARCH}" == "x86_64" ];then
+ cp -ra BloodHound-linux-x64/* "${pkgdir}/opt/${pkgname}/"
+ elif [ "${CARCH}" == "aarch64" ];then
+ cp -ra BloodHound-linux-arm64/* "${pkgdir}/opt/${pkgname}/"
+ elif [ "${CARCH}" == "armv7h" ];then
+ cp -ra BloodHound-linux-armv7l/* "${pkgdir}/opt/${pkgname}/"
+ fi
+ install -dm755 "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/BloodHound" "${pkgdir}/usr/bin/${pkgname}"
+
+ # install manpage
+ install -Dm644 docs/_build/man/bloodhound.1 "${pkgdir}/usr/share/man/man1/bloodhound.1"
+
+ # install html docs
+ mkdir -p "${pkgdir}/opt/${pkgname}/docs/"
+ cp -ra docs/_build/html/* "${pkgdir}/opt/${pkgname}/docs/"
+
+ # Install windows collectors
+ mkdir -p "${pkgdir}/opt/${pkgname}/collectors/"
+ cp -ra Collectors/* "${pkgdir}/opt/${pkgname}/collectors/"
+ mkdir -p "${pkgdir}/usr/share/windows-binaries/"
+ ln -s "/opt/${pkgname}/collectors" "${pkgdir}/usr/share/windows-binaries/bloodhound-collectors"
+
+ # Install icons
+ install -Dm644 "src/img/logo-white-on-transparent.png" "${pkgdir}/usr/share/pixmaps/bloodhound-white.png"
+ install -Dm644 "src/img/logo-white-transparent.png" "${pkgdir}/usr/share/pixmaps/bloodhound-rbw.png"
+ install -Dm644 "src/img/logo-white-transparent-full.png" "${pkgdir}/usr/share/pixmaps/bloodhound-redandblack.png"
+}
diff --git a/bloodhound.desktop b/bloodhound.desktop
new file mode 100644
index 000000000000..968b489bec39
--- /dev/null
+++ b/bloodhound.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Bloodhound
+Exec=/opt/bloodhound/BloodHound %U
+Terminal=false
+Type=Application
+Icon=bloodhound-rbw.png
+StartupWMClass=bloodhound
+Comment=BloodHound uses graph theory to reveal the hidden and often unintended relationships within an Active Directory environment.
+GenericName=Bloodhound
+StartupNotify=true
+Categories=Utility;Security;
+Keywords=bloodhound;