summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb00rt00s2015-06-08 22:08:22 +0200
committerb00rt00s2015-06-08 22:08:22 +0200
commit634ab667476f7f389e6fe02069b40a7b04de0a2a (patch)
tree35fe3905f57ab5bd13b9fe3eb8357658a24de244
downloadaur-634ab667476f7f389e6fe02069b40a7b04de0a2a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--COPYING22
-rw-r--r--PKGBUILD50
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e54e4b838f9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blt
+ pkgdesc = Adds new commands and widgets to the Tcl interpreter.
+ pkgver = 2.4z
+ pkgrel = 11
+ url = http://blt.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = tk
+ source = git+https://github.com/thillux/blt.git
+ source = COPYING
+ md5sums = SKIP
+ md5sums = 49ab6c4bd72e045108c92d839368df04
+
+pkgname = blt
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..6b9e20d5cb86
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,22 @@
+/*
+ * Copyright 1993-1998 Lucent Technologies, Inc.
+ *
+ * Permission to use, copy, modify, and distribute this software and
+ * its documentation for any purpose and without fee is hereby
+ * granted, provided that the above copyright notice appear in all
+ * copies and that both that the copyright notice and warranty
+ * disclaimer appear in supporting documentation, and that the names
+ * of Lucent Technologies any of their entities not be used in
+ * advertising or publicity pertaining to distribution of the software
+ * without specific, written prior permission.
+ *
+ * Lucent Technologies disclaims all warranties with regard to this
+ * software, including all implied warranties of merchantability and
+ * fitness. In no event shall Lucent Technologies be liable for any
+ * special, indirect or consequential damages or any damages
+ * whatsoever resulting from loss of use, data or profits, whether in
+ * an action of contract, negligence or other tortuous action, arising
+ * out of or in connection with the use or performance of this
+ * software.
+ *
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5538472fc9f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Markus Theil <aur@thillux.de>
+# Contributor: Oleg Smirnov <oleg.smirnov@gmail.com>
+# Contributor: Jason Taylor <jftaylor21@gmail.com>
+# Contributor: Christophe Gueret <tolgam@homegnu.net>
+# Contributor: b00rt00s <b_ged@linuksowo.pl>
+pkgname=blt
+pkgver=2.4z
+pkgrel=11
+pkgdesc="Adds new commands and widgets to the Tcl interpreter."
+url="http://blt.sourceforge.net"
+license="custom"
+depends=('tk')
+makedepends=('git')
+arch=('i686' 'x86_64')
+source=('git+https://github.com/thillux/blt.git'
+ COPYING)
+md5sums=('SKIP'
+ '49ab6c4bd72e045108c92d839368df04')
+_gitname=blt
+
+build() {
+ # configure
+ cd ${srcdir}/${pkgname}
+
+ ./configure \
+ --prefix=/usr \
+ --with-tcl=/usr/lib \
+ --with-x --x-includes=/usr/include \
+ --x-libraries=/usr/lib \
+ --mandir=/usr/share/man
+
+ # Compile
+ make -j 1 || return 1
+}
+
+package() {
+ # Fix for the man directory
+ mkdir -p ${pkgdir}/usr/share/man
+
+ # Add license
+ mkdir -p ${pkgdir}/usr/share/licenses/blt
+ cp ${srcdir}/COPYING ${pkgdir}/usr/share/licenses/blt
+
+ cd ${srcdir}/${pkgname}
+ make -j 1 INSTALL_ROOT=${pkgdir} install
+
+ # Delete man file, it is still owned by extra/tk
+ rm ${pkgdir}/usr/share/man/mann/bitmap.n
+ rm ${pkgdir}/usr/share/man/mann/busy.n
+}