aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2016-08-22 19:07:24 -0400
committerZeke Sonxx2016-08-22 19:07:24 -0400
commita5edb3d5766bc9792e64df0152cfc97e4717105b (patch)
treec26a9fb48cf918e84f31b9335750e59b9f899db4
downloadaur-a5edb3d5766bc9792e64df0152cfc97e4717105b.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--README.md3
-rw-r--r--blt4l.install7
5 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e39778abc76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = blt4l
+ pkgdesc = Mod loader for Payday 2 (non-Steam runtime only)
+ pkgver = 1.2_r1
+ pkgrel = 1
+ url = https://github.com/blt4linux/blt4l
+ install = blt4l.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = curl
+ depends = openssl
+ depends = zlib
+ conflicts = blt4l-git
+ source = blt4l::git+https://github.com/blt4linux/blt4l#tag=1.2-r1
+ md5sums = SKIP
+
+pkgname = blt4l
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba9a49a3b60a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+blt4l
+src
+pkg
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4cc6b817a9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034,SC2148,SC2154
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+pkgname=blt4l
+pkgver=1.2_r1
+pkgrel=1
+pkgdesc="Mod loader for Payday 2 (non-Steam runtime only)"
+arch=('i686' 'x86_64')
+url="https://github.com/blt4linux/blt4l"
+license=('GPL3')
+groups=()
+depends=('curl' 'openssl' 'zlib')
+makedepends=('git' 'cmake')
+provides=()
+conflicts=("blt4l-git")
+replaces=()
+backup=()
+options=()
+install=blt4l.install
+source=("blt4l::git+https://github.com/blt4linux/blt4l#tag=${pkgver/_/-}")
+noextract=()
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/blt4l" || exit
+ git submodule init
+ git submodule update
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build" || exit
+ cmake "$srcdir/blt4l"
+ make
+}
+
+package() {
+ install -D -m644 "${srcdir}/build/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader.so"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..cfde775f2aa5
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# blt4l eventual AUR package
+
+Sitting in GitHub for the moment so that I can share what I'm working on without publishing it on the AUR.
diff --git a/blt4l.install b/blt4l.install
new file mode 100644
index 000000000000..592193828891
--- /dev/null
+++ b/blt4l.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Your installation of blt4l is not yet done!
+You'll need to set launch options in Steam for Payday 2:
+LD_PRELOAD=\"\$LD_PRELOAD /usr/lib/blt4l/libblt_loader.so\" %command%
+And install the base Lua code, instructions here:
+https://github.com/blt4linux/blt4l"
+}