aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2017-09-15 17:32:35 -0400
committerZeke Sonxx2017-09-15 17:32:35 -0400
commite55c840213d0c60afe201a8aac135d0ae7afaf22 (patch)
tree8db57edff06efda6f3b798b640ac9d9077c399a0
parentcb3cd005b5b47f0a84213ac12256f3df436fa546 (diff)
downloadaur-e55c840213d0c60afe201a8aac135d0ae7afaf22.tar.gz
Refactor into new launcher script, includes steamrt version now, pkgrel2
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
-rw-r--r--blt4l.install14
4 files changed, 49 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0bf6b35b75..2c1ae43d3da8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blt4l
- pkgdesc = Mod loader for Payday 2 (non-Steam runtime only)
+ pkgdesc = Mod loader for Payday 2
pkgver = 2.0_pre2_r1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/blt4linux/blt4l
install = blt4l.install
arch = i686
@@ -12,9 +12,18 @@ pkgbase = blt4l
depends = curl
depends = openssl
depends = zlib
+ depends = zenity
conflicts = blt4l-git
+ replaces = blt4l-runtime-bin
source = blt4l::git+https://github.com/blt4linux/blt4l#tag=2.0-pre2-r1
+ source = https://raw.githubusercontent.com/blt4linux/blt4l_launcher/6d3da8df567f9d541df8fc10194febf19a80afde/blt4l.sh
+ source = https://github.com/blt4linux/blt4l/releases/download/2.0-pre2-r1/blt4l_2.0-pre2-r1_Ubuntu_Precise_.SteamRT.tar.xz
md5sums = SKIP
+ md5sums = 0c01af7e5ddb43fb7d860878b1fa7e73
+ md5sums = 09ed0bc01c5317e7d445311aac622207
+ sha512sums = SKIP
+ sha512sums = ef7bbcd9049bd8424cf8f5430c9528e4489fb03be77ded164eb5361051d1eadfaa5d48437089bd3acfd7970f167a0e310cb4c777dcacbe66dafc197529b9fe27
+ sha512sums = 3d4e9ca92e4fb8e6c504e7297f0792e49f89b7a3f31eb1203c4f78570103a2dda054b91a13abff09244a7d338af66bc83e971efdc23b9a5b9aa199160ac6717b
pkgname = blt4l
diff --git a/.gitignore b/.gitignore
index ba9a49a3b60a..db7f75801bb5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@ blt4l
src
pkg
*.pkg.*
+blt4l_*
+blt4l.sh
diff --git a/PKGBUILD b/PKGBUILD
index 13f5a3df8f8b..45b688c35229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,31 @@
# 2.0-pre2.1
pkgname=blt4l
pkgver=2.0_pre2_r1
-pkgrel=1
-pkgdesc="Mod loader for Payday 2 (non-Steam runtime only)"
+pkgrel=2
+pkgdesc="Mod loader for Payday 2"
arch=('i686' 'x86_64')
url="https://github.com/blt4linux/blt4l"
license=('GPL3')
groups=()
-depends=('curl' 'openssl' 'zlib')
+depends=('curl' 'openssl' 'zlib' 'zenity')
makedepends=('git' 'cmake')
provides=()
conflicts=("blt4l-git")
-replaces=()
+replaces=("blt4l-runtime-bin")
backup=()
options=()
install=blt4l.install
-source=("blt4l::git+https://github.com/blt4linux/blt4l#tag=${pkgver//_/-}")
+__steamrtfilename="blt4l_${pkgver//_/-}_Ubuntu_Precise_.SteamRT"
+source=("blt4l::git+https://github.com/blt4linux/blt4l#tag=${pkgver//_/-}"
+ "https://raw.githubusercontent.com/blt4linux/blt4l_launcher/6d3da8df567f9d541df8fc10194febf19a80afde/blt4l.sh"
+ "https://github.com/blt4linux/blt4l/releases/download/${pkgver//_/-}/${__steamrtfilename}.tar.xz")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '0c01af7e5ddb43fb7d860878b1fa7e73'
+ '09ed0bc01c5317e7d445311aac622207')
+sha512sums=('SKIP'
+ 'ef7bbcd9049bd8424cf8f5430c9528e4489fb03be77ded164eb5361051d1eadfaa5d48437089bd3acfd7970f167a0e310cb4c777dcacbe66dafc197529b9fe27'
+ '3d4e9ca92e4fb8e6c504e7297f0792e49f89b7a3f31eb1203c4f78570103a2dda054b91a13abff09244a7d338af66bc83e971efdc23b9a5b9aa199160ac6717b')
prepare() {
cd "$srcdir/blt4l" || exit
@@ -36,5 +44,16 @@ build() {
}
package() {
+ # Compiled binary
install -D -m644 "${srcdir}/build/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader.so"
+
+ # Steam Runtime binary
+ install -D -m644 "${srcdir}/${__steamrtfilename//.SteamRT/(SteamRT)}/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader_steamrt.so"
+
+ # Launcher
+ install -D -m755 "${srcdir}/blt4l.sh" "${pkgdir}/usr/bin/blt4l"
+
+ # Mods Folder
+ cp -r "${srcdir}/blt4l/lua/Payday-2-BLT-Lua/mods/" "${pkgdir}/usr/lib/blt4l/mods/"
+ chmod -R 755 "${pkgdir}/usr/lib/blt4l/mods/"
}
diff --git a/blt4l.install b/blt4l.install
index 592193828891..357c376bdf40 100644
--- a/blt4l.install
+++ b/blt4l.install
@@ -1,7 +1,15 @@
+# shellcheck shell=bash
+
post_install() {
echo "Your installation of blt4l is not yet done!
You'll need to set launch options in Steam for Payday 2:
-LD_PRELOAD=\"\$LD_PRELOAD /usr/lib/blt4l/libblt_loader.so\" %command%
-And install the base Lua code, instructions here:
-https://github.com/blt4linux/blt4l"
+ blt4l %command%
+The mods/ folder will be automatically created on launch (if it doesn't already exist)."
+}
+
+post_upgrade() {
+ echo "If you were using the previous package, you need to update your launch options.
+You'll need to set launch options in Steam for Payday 2:
+ blt4l %command%
+The mods/ folder will be automatically created on launch (if it doesn't already exist)."
}