summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2016-08-30 14:13:12 -0400
committerZeke Sonxx2016-08-30 14:13:12 -0400
commit076287ff9188eedb9c088512797a3f13b49ee59a (patch)
tree9d5d1fdf7975e306230011243cd3a2c72bfb4b90
downloadaur-076287ff9188eedb9c088512797a3f13b49ee59a.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
-rw-r--r--blt4l.install7
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d5b92c01429
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = blt4l-runtime-bin
+ pkgdesc = Mod loader for Payday 2 (Steam runtime, bin version)
+ pkgver = 1.2_r1
+ pkgrel = 1
+ url = https://github.com/blt4linux/blt4l
+ install = blt4l.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = curl
+ depends = openssl
+ depends = zlib
+ source = https://github.com/blt4linux/blt4l/releases/download/1.2-r1/blt4l_1.2-r1_Ubuntu-precise-steamrt.tar.xz
+ md5sums = 3c5615ad3d370e939b40eca88c81e8e7
+ sha512sums = e4ee78051a724686d2844e80b14feecaef46d9db61216f8daa5718563280e37d905b08b0608ee019768daab547b7e4acb0626f1b752501cd0b070bad0d748d37
+
+pkgname = blt4l-runtime-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5749b3753b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+blt4l*
+!blt4l.install
+src
+pkg
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d9fb6fb87a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034,SC2148,SC2154
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+pkgname=blt4l-runtime-bin
+pkgver=1.2_r1
+pkgrel=1
+pkgdesc="Mod loader for Payday 2 (Steam runtime, bin version)"
+arch=('i686' 'x86_64')
+url="https://github.com/blt4linux/blt4l"
+license=('GPL3')
+groups=()
+depends=('curl' 'openssl' 'zlib')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=blt4l.install
+__filename="blt4l_${pkgver/_/-}_Ubuntu-precise-steamrt"
+source=("https://github.com/blt4linux/blt4l/releases/download/${pkgver/_/-}/${__filename}.tar.xz")
+noextract=()
+md5sums=('3c5615ad3d370e939b40eca88c81e8e7')
+sha512sums=('e4ee78051a724686d2844e80b14feecaef46d9db61216f8daa5718563280e37d905b08b0608ee019768daab547b7e4acb0626f1b752501cd0b070bad0d748d37')
+
+package() {
+ install -D -m644 "${srcdir}/${__filename}/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader_steamrt.so"
+}
diff --git a/blt4l.install b/blt4l.install
new file mode 100644
index 000000000000..9e20bb14ed77
--- /dev/null
+++ b/blt4l.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Your installation of blt4l is not yet done!
+You'll need to set launch options in Steam for Payday 2:
+LD_PRELOAD=\"\$LD_PRELOAD /usr/lib/blt4l/libblt_loader_steamrt.so\" %command%
+And install the base Lua code, instructions here:
+https://github.com/blt4linux/blt4l"
+}