summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2017-06-25 17:24:51 -0400
committerZeke Sonxx2017-06-25 17:25:13 -0400
commitc5db01370d0be8de2de9f9f9b77bc9e23809c5f1 (patch)
tree343947e7f88f05776214c180509eb7ee8f3be825
parent7f3870e6420fc82ac3f4986dd7dbc4ef27d8cb85 (diff)
downloadaur-c5db01370d0be8de2de9f9f9b77bc9e23809c5f1.tar.gz
Update to 1.3-r1-1, preliminary work on the installer
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7644fcf2986f..335f7919a089 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blt4l-runtime-bin
pkgdesc = Mod loader for Payday 2 (Steam runtime, bin version)
- pkgver = 1.3
+ pkgver = 1.3_r1_1
pkgrel = 1
url = https://github.com/blt4linux/blt4l
install = blt4l.install
@@ -10,9 +10,9 @@ pkgbase = blt4l-runtime-bin
depends = curl
depends = openssl
depends = zlib
- source = https://github.com/blt4linux/blt4l/releases/download/1.3/blt4l_1.3_Ubuntu-precise-steamrt.tar.xz
- md5sums = f15430924274f36eb7ee2bb779c3ea13
- sha512sums = 07bbbaf7c7f6c73cd724d86e41f058d3e86aa0acafffb337001615b727ed050b40920b4f6df8a10f516d47ef5f66c8ff3306df974e598c88bc99fa6de1cc7a33
+ source = https://github.com/blt4linux/blt4l/releases/download/1.3-r1-1/blt4l_1.3-r1-1_Ubuntu-precise-steamrt.tar.xz
+ md5sums = 625bb2a871b628446a57818610301a36
+ sha512sums = 9f2359d1fe28ed31b907a2877b6ad1eb42d297d70462d0baecff01e18b636f7d27355b64ff61355afdb4ea78f5a9d3fae7d834d5e0d33796fd95150f5a837f15
pkgname = blt4l-runtime-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2c35760dd1c6..8f08017c499e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# shellcheck disable=SC2034,SC2148,SC2154
# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
pkgname=blt4l-runtime-bin
-pkgver=1.3
+pkgver=1.3_r1_1
pkgrel=1
pkgdesc="Mod loader for Payday 2 (Steam runtime, bin version)"
arch=('i686' 'x86_64')
url="https://github.com/blt4linux/blt4l"
license=('GPL3')
groups=()
-depends=('curl' 'openssl' 'zlib')
+depends=('curl' 'openssl' 'zlib') # 'python2' (for the installer)
makedepends=()
provides=()
conflicts=()
@@ -17,12 +17,27 @@ replaces=()
backup=()
options=()
install=blt4l.install
-__filename="blt4l_${pkgver/_/-}_Ubuntu-precise-steamrt"
-source=("https://github.com/blt4linux/blt4l/releases/download/${pkgver/_/-}/${__filename}.tar.xz")
+__filename="blt4l_${pkgver//_/-}_Ubuntu-precise-steamrt"
+source=("https://github.com/blt4linux/blt4l/releases/download/${pkgver//_/-}/${__filename}.tar.xz")
noextract=()
-md5sums=('f15430924274f36eb7ee2bb779c3ea13')
-sha512sums=('07bbbaf7c7f6c73cd724d86e41f058d3e86aa0acafffb337001615b727ed050b40920b4f6df8a10f516d47ef5f66c8ff3306df974e598c88bc99fa6de1cc7a33')
+md5sums=('625bb2a871b628446a57818610301a36')
+sha512sums=('9f2359d1fe28ed31b907a2877b6ad1eb42d297d70462d0baecff01e18b636f7d27355b64ff61355afdb4ea78f5a9d3fae7d834d5e0d33796fd95150f5a837f15')
package() {
install -D -m644 "${srcdir}/${__filename}/libblt_loader.so" "${pkgdir}/usr/lib/blt4l/libblt_loader_steamrt.so"
+
+ ## Preliminary work on including the installer
+ ## I'll need to patch the installer for this to be usable.
+ # # Base Lua, needed by the game
+ # cp -r "${srcdir}/${__filename}/mods" "${pkgdir}/usr/lib/blt4l/mods"
+ # chmod 755 "${pkgdir}/usr/lib/blt4l/mods"
+ #
+ # # Installer scripts
+ # cp -r "${srcdir}/${__filename}/.installer" "${pkgdir}/usr/lib/blt4l/.installer"
+ # chmod -R 755 "${pkgdir}/usr/lib/blt4l/.installer"
+ # install -D -m755 "${srcdir}/${__filename}/install.sh" "${pkgdir}/usr/lib/blt4l/install.sh"
+ #
+ # # Setup the install binary
+ # mkdir -p "${pkgdir}/usr/bin/"
+ # ln -s "/usr/lib/blt4l/install.sh" "${pkgdir}/usr/bin/blt4l-installer"
}