summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimonadi2022-12-25 19:32:44 +0100
committersimonadi2022-12-25 19:32:44 +0100
commit0bc48260c2a7d01a81b25a3e112d7926045bfcd3 (patch)
treeb5a0f032eb4a5ec5123e4d7c9dadc990cad7a2f6
downloadaur-0bc48260c2a7d01a81b25a3e112d7926045bfcd3.tar.gz
added basic files
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3407c347ff9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bltui
+ pkgdesc = Bluetooth TUI
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/simonadi/bltui
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = bluez
+ provides = bltui
+ source = git+https://github.com/simonadi/bltui.git
+ sha256sums = 49ab1b965a7368543375ba0fe78b9f1ec2c2db3343afb053de783dd5d89cd0aa
+
+pkgname = bltui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b7a132c6c07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer : Simon <viknesh.adi@gmail.com>
+pkgname=bltui
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Bluetooth TUI"
+arch=("x86_64")
+license=("MIT")
+url="https://github.com/simonadi/bltui"
+depends=("bluez")
+makedepends=("cargo" "git")
+provides=("bltui")
+# source=("${pkgname}-${pkgver}.tar.gz::https://github.com/simonadi/${pkgname}/archive/${pkgver}.tar.gz")
+# source=("${pkgname}-${pkgver}.tar.gz")
+source=("git+https://github.com/simonadi/bltui.git")
+
+
+pkgver() {
+ convco version --bump
+}
+
+prepare() {
+ cd $pkgname
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd $pkgname
+ cargo build --frozen --release
+}
+
+check() {
+ cd $pkgname
+ cargo check --frozen --release
+}
+
+package() {
+ cd $pkgname
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}
+
+sha256sums=('49ab1b965a7368543375ba0fe78b9f1ec2c2db3343afb053de783dd5d89cd0aa') \ No newline at end of file