summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimonadi2022-12-26 12:25:04 +0100
committersimonadi2022-12-26 12:25:04 +0100
commitb7b5983275c358e725d755f1b07d1bee0614c159 (patch)
tree28e17b16dac8b5f568e8bcae2f76ddc4a03d79e0
downloadaur-b7b5983275c358e725d755f1b07d1bee0614c159.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22e2dc83444b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bltui-git
+ pkgdesc = Bluetooth TUI
+ pkgver = 0.1.3
+ pkgrel = 2
+ url = https://github.com/simonadi/bltui
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = bluez
+ provides = bltui
+ conflicts = bltui
+ source = bltui::git+https://github.com/simonadi/bltui.git
+ sha256sums = SKIP
+
+pkgname = bltui-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d7d5532ffbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Simon <viknesh.adi@gmail.com>
+_pkgname=bltui
+pkgname=${_pkgname}-git
+pkgver=0.1.3
+pkgrel=2
+pkgdesc="Bluetooth TUI"
+arch=("x86_64")
+license=("MIT")
+url="https://github.com/simonadi/bltui"
+depends=("bluez")
+makedepends=("cargo" "git")
+provides=("bltui")
+conflicts=("bltui")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $_pkgname
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd $_pkgname
+ cargo build --frozen --release
+}
+
+check() {
+ cd $_pkgname
+ cargo check --frozen --release
+}
+
+package() {
+ cd $_pkgname
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$_pkgname"
+}