summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Springer2020-08-12 00:58:33 +0200
committerFelix Springer2020-08-12 00:58:33 +0200
commit08b715c34251a79ff0ba29e107c843628a500b8d (patch)
treee5b8e5f15ae794414c0cfd134ca44fe9cfec402e
parent6c1a9c57619f68ace324e65a7610921a645e426d (diff)
downloadaur-08b715c34251a79ff0ba29e107c843628a500b8d.tar.gz
bump version to 0.2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--compile-dynamically.patch21
3 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b5f7916bd3..3dd58661b093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blucontrol
pkgdesc = Configurable blue light filter
- pkgver = 0.2.0.0
- pkgrel = 2
+ pkgver = 0.2.1.0
+ pkgrel = 1
url = https://github.com/jumper149/blucontrol
arch = x86_64
license = custom:BSD3
@@ -16,11 +16,11 @@ pkgbase = blucontrol
depends = haskell-x11
depends = libx11
depends = libxrandr
- source = https://github.com/jumper149/blucontrol/archive/v0.2.0.0.tar.gz
+ source = https://github.com/jumper149/blucontrol/archive/v0.2.1.0.tar.gz
source = compile-dynamically.patch
source = Setup.hs
- sha256sums = b187c341ab66ac54970b3b4a3ed7e28162da85219fa33342599eefdc2c571a36
- sha256sums = 5d9a96b72f4f4ee68a767334cc4dbcf82d8a91f09f000e1900bd399d17363cdb
+ sha256sums = 131632f6a952cb8325726c368a8fedd670aa7e0c9ce57b4cc7dc00270a4e6f39
+ sha256sums = 5f535fb64bf4da30547721608039eab4a399547a752dbf405baff36f0c9f6286
sha256sums = 5066653559d4d6134b022d66a634a17fdcf8db35d28b447e581fec284afa4689
pkgname = blucontrol
diff --git a/PKGBUILD b/PKGBUILD
index f5c8f3fda056..4c8a5d4f5095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Felix Springer <felixspringer149@gmail.com>
pkgname=blucontrol
-pkgver=0.2.0.0
-pkgrel=2
+pkgver=0.2.1.0
+pkgrel=1
pkgdesc="Configurable blue light filter"
url="https://github.com/jumper149/${pkgname}"
license=('custom:BSD3')
@@ -26,8 +26,8 @@ source=(
"Setup.hs"
)
sha256sums=(
- 'b187c341ab66ac54970b3b4a3ed7e28162da85219fa33342599eefdc2c571a36'
- '5d9a96b72f4f4ee68a767334cc4dbcf82d8a91f09f000e1900bd399d17363cdb'
+ '131632f6a952cb8325726c368a8fedd670aa7e0c9ce57b4cc7dc00270a4e6f39'
+ '5f535fb64bf4da30547721608039eab4a399547a752dbf405baff36f0c9f6286'
'5066653559d4d6134b022d66a634a17fdcf8db35d28b447e581fec284afa4689'
)
diff --git a/compile-dynamically.patch b/compile-dynamically.patch
index 9e6a4ddbff06..8dfbaafe42c9 100644
--- a/compile-dynamically.patch
+++ b/compile-dynamically.patch
@@ -1,11 +1,10 @@
-diff -ura blucontrol.orig/src/Blucontrol/Main/CLI.hs blucontrol/src/Blucontrol/Main/CLI.hs
---- blucontrol.orig/src/Blucontrol/Main/CLI.hs 2020-08-02 01:26:50.529886479 +0200
-+++ blucontrol/src/Blucontrol/Main/CLI.hs 2020-08-02 01:39:45.761627593 +0200
-@@ -79,6 +79,7 @@
- runProcess "ghc" [ "--make"
- , configLeafname
- , "-main-is", "main"
-+ , "-dynamic"
- , "-v0"
- , "-o", cacheDir </> compiledConfigLeafname
- ] (Just configDir) Nothing Nothing Nothing Nothing
+diff -ura blucontrol-0.2.0.0.orig/src/Blucontrol/Main/GHC/Internal.hs blucontrol-0.2.0.0/src/Blucontrol/Main/GHC/Internal.hs
+--- blucontrol-0.2.0.0.orig/src/Blucontrol/Main/GHC/Internal.hs 2020-08-12 00:12:17.591886622 +0200
++++ blucontrol-0.2.0.0/src/Blucontrol/Main/GHC/Internal.hs 2020-08-12 00:09:06.162270141 +0200
+@@ -7,5 +7,5 @@
+ ghcBinary = "ghc"
+
+ ghcAdditionalFlags :: [String]
+-ghcAdditionalFlags = [
++ghcAdditionalFlags = [ "-dynamic"
+ ]