summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Springer2020-08-02 15:59:51 +0200
committerFelix Springer2020-08-02 15:59:51 +0200
commit3d74e2496382c1b9e9ff582b4fa7e0ecee9b84b8 (patch)
tree7fc631fa74f189f27fc343f7cf6f7484f72549eb
parentef9022d2441c88d96d171010ce14641b7dadd6d9 (diff)
downloadaur-3d74e2496382c1b9e9ff582b4fa7e0ecee9b84b8.tar.gz
dont use git as makedepend, use specific commit to download source (TODO: change to versions-refs later), fix indentation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ebc4df211d4..3f5e272b850b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bludigon
pkgver = 0.1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jumper149/bludigon
arch = x86_64
license = custom:BSD3
@@ -15,7 +15,7 @@ pkgbase = bludigon
depends = haskell-x11
depends = libx11
depends = libxrandr
- source = git+https://github.com/jumper149/bludigon.git
+ source = https://github.com/jumper149/bludigon/archive/d315d4193bfedbb0f7b1d9ab06c6010e71bee2cc
source = compile-dynamically.patch
source = Setup.hs
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d0d03052b859..3607ba657ec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=bludigon
pkgver=0.1.0.0
-pkgrel=1
+_gitcommit=d315d4193bfedbb0f7b1d9ab06c6010e71bee2cc
+pkgrel=2
pkgdesc=""
url="https://github.com/jumper149/bludigon"
license=('custom:BSD3')
@@ -21,7 +22,7 @@ depends=(
'libxrandr'
)
source=(
- "git+https://github.com/jumper149/${pkgname}.git"
+ "https://github.com/jumper149/${pkgname}/archive/${_gitcommit}"
"compile-dynamically.patch"
"Setup.hs"
)
@@ -32,14 +33,14 @@ sha256sums=(
)
prepare() {
- cd "${pkgname}"
+ cd "${pkgname}-${_gitcommit}"
patch -p1 -i "${srcdir}/compile-dynamically.patch"
cp "${srcdir}/Setup.hs" "./"
}
build() {
- cd "${pkgname}"
+ cd "${pkgname}-${_gitcommit}"
runhaskell Setup configure -O \
--disable-library-vanilla \
@@ -62,19 +63,19 @@ build() {
}
check() {
- cd ${pkgname}
+ cd "${pkgname}-${_gitcommit}"
runhaskell Setup test
}
package() {
- cd "${pkgname}"
+ cd "${pkgname}-${_gitcommit}"
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
- runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: