summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-13 15:15:33 +0800
committerzxp198210052023-06-13 15:15:33 +0800
commit0bd84ca4ce1aa061d37de94397e3762244c13406 (patch)
tree15f283b461831762f2e136acef3a90df6772ade8
downloadaur-0bd84ca4ce1aa061d37de94397e3762244c13406.tar.gz
first release
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD27
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff87c4290ad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = bluebubbles-bin
+ pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
+ pkgver = 1.12.2
+ pkgrel = 1
+ url = https://bluebubbles.app/
+ arch = aarch64
+ arch = x86_64
+ license = Apache
+ makedepends = gendesk
+ depends = glib2
+ depends = libepoxy
+ depends = vlc
+ depends = gcc-libs
+ depends = at-spi2-core
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = harfbuzz
+ depends = glibc
+ depends = pango
+ depends = libdbusmenu-glib
+ depends = libnotify
+ depends = libappindicator-gtk3
+ depends = gtk3
+ conflicts = bluebubbles
+ conflicts = bluebubbles-appimage
+ conflicts = bluebubbles-desktop-app
+ noextract = bluebubbles-1.12.2-x86_64.tar
+ source_aarch64 = bluebubbles-1.12.2-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.2%2B55/bluebubbles-linux-aarch64.tar
+ sha256sums_aarch64 = 9472215126987c8508bf8e595429d1eba1c6a9041e2eded6ae24736070036e36
+ source_x86_64 = bluebubbles-1.12.2-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.2%2B55/bluebubbles-linux-x86_64.tar
+ sha256sums_x86_64 = 4ac735a698fca2cfab0461e466a9ca33e3c722e77a5ee31b6cef9bc2d0db5909
+
+pkgname = bluebubbles-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cab8aa7dc13f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="bluebubbles-bin"
+pkgver=1.12.2
+pkgrel=1
+pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
+arch=('aarch64' 'x86_64')
+url="https://bluebubbles.app/"
+_githuburl="https://github.com/BlueBubblesApp/bluebubbles-app"
+license=('Apache')
+options=()
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage" "${pkgname%-bin}-desktop-app")
+depends=('glib2' 'libepoxy' 'vlc' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' \
+ 'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3')
+makedepends=('gendesk')
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B55/${pkgname%-bin}-linux-aarch64.tar")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B55/${pkgname%-bin}-linux-x86_64.tar")
+noextract=("${pkgname%-bin}-${pkgver}-${CARCH}.tar")
+sha256sums_aarch64=('9472215126987c8508bf8e595429d1eba1c6a9041e2eded6ae24736070036e36')
+sha256sums_x86_64=('4ac735a698fca2cfab0461e466a9ca33e3c722e77a5ee31b6cef9bc2d0db5909')
+
+package() {
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.tar" -C "${pkgdir}/opt/${pkgname%-bin}" --gname root --uname root
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/data/flutter_assets/assets/icon/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "BlueBubbles" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file