summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-20 13:13:16 +0800
committerzxp198210052023-10-20 13:13:16 +0800
commit543d6410bba32b6b2bc10af5dd93db0310565848 (patch)
tree689a714fc50800fc16d4220a9a7b58e8c0d501f2
parentbc6f2c738367250542bdaa41820929e48ac55951 (diff)
downloadaur-543d6410bba32b6b2bc10af5dd93db0310565848.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4517751aa2c7..355b8c763240 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
pkgver = 1.12.4
- pkgrel = 2
+ pkgrel = 3
url = https://bluebubbles.app/
arch = aarch64
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = bluebubbles-bin
makedepends = gendesk
depends = glib2
depends = libepoxy
- depends = vlc
+ depends = webkit2gtk-4.1
depends = gcc-libs
depends = at-spi2-core
depends = gdk-pixbuf2
@@ -22,6 +22,7 @@ pkgbase = bluebubbles-bin
depends = libnotify
depends = libappindicator-gtk3
depends = gtk3
+ depends = libsoup3
provides = bluebubbles=1.12.4
conflicts = bluebubbles
source_aarch64 = bluebubbles-1.12.4-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.4%2B58/bluebubbles-linux-aarch64.tar
diff --git a/PKGBUILD b/PKGBUILD
index ba1bf3f027e1..5fc23a24ff61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bluebubbles-bin
_pkgname=BlueBubbles
pkgver=1.12.4
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=('aarch64' 'x86_64')
url="https://bluebubbles.app/"
@@ -10,15 +10,15 @@ _githuburl="https://github.com/BlueBubblesApp/bluebubbles-app"
license=('Apache')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('glib2' 'libepoxy' 'vlc' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' 'mpv' \
- 'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3')
+depends=('glib2' 'libepoxy' 'webkit2gtk-4.1' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' 'mpv' \
+ 'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3' 'libsoup3')
makedepends=('gendesk')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-aarch64.tar")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-x86_64.tar")
sha256sums_aarch64=('63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379')
sha256sums_x86_64=('616ab5cfd458cb3ba1a8fea163443e686173a6312d806e42a08e920adcfce97b')
-prepare() {
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+build() {
+ gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
}
package() {
install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin,usr/lib}
@@ -27,6 +27,5 @@ package() {
install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/opt/${pkgname%-bin}"
ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
ln -sf "/usr/lib/libmpv.so" "${pkgdir}/usr/lib/libmpv.so.1"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "BlueBubbles" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file