summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-29 09:21:32 +0800
committerzxp198210052023-08-29 09:21:32 +0800
commit6b6c185511de64e3e44b0ad611ee0002d55722b2 (patch)
tree12f12677b13e40cb8044a20627ae2dbd13e0a285
parent6dc3632854811dfc694f26176065b2feb3e23830 (diff)
downloadaur-6b6c185511de64e3e44b0ad611ee0002d55722b2.tar.gz
update to 1.12.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0f3809c1bfd..2be66652871e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
- pkgver = 1.12.2
- pkgrel = 3
+ pkgver = 1.12.4
+ pkgrel = 1
url = https://bluebubbles.app/
arch = aarch64
arch = x86_64
@@ -21,12 +21,12 @@ pkgbase = bluebubbles-bin
depends = libnotify
depends = libappindicator-gtk3
depends = gtk3
- provides = bluebubbles=1.12.2
+ provides = bluebubbles=1.12.4
conflicts = bluebubbles
- noextract = bluebubbles-1.12.2-x86_64.tar
- source_aarch64 = bluebubbles-1.12.2-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.2%2B55/bluebubbles-linux-aarch64.tar
- sha256sums_aarch64 = 9472215126987c8508bf8e595429d1eba1c6a9041e2eded6ae24736070036e36
- source_x86_64 = bluebubbles-1.12.2-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.2%2B55/bluebubbles-linux-x86_64.tar
- sha256sums_x86_64 = 4ac735a698fca2cfab0461e466a9ca33e3c722e77a5ee31b6cef9bc2d0db5909
+ noextract = bluebubbles-1.12.4-x86_64.tar
+ source_aarch64 = bluebubbles-1.12.4-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.4%2B58/bluebubbles-linux-aarch64.tar
+ sha256sums_aarch64 = 63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379
+ source_x86_64 = bluebubbles-1.12.4-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.4%2B58/bluebubbles-linux-x86_64.tar
+ sha256sums_x86_64 = 616ab5cfd458cb3ba1a8fea163443e686173a6312d806e42a08e920adcfce97b
pkgname = bluebubbles-bin
diff --git a/PKGBUILD b/PKGBUILD
index c44f2601516e..b3948e13057e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluebubbles-bin
-pkgver=1.12.2
-pkgrel=3
+pkgver=1.12.4
+pkgrel=1
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=('aarch64' 'x86_64')
url="https://bluebubbles.app/"
@@ -12,11 +12,11 @@ conflicts=("${pkgname%-bin}")
depends=('glib2' 'libepoxy' 'vlc' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' \
'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3')
makedepends=('gendesk')
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B55/${pkgname%-bin}-linux-aarch64.tar")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B55/${pkgname%-bin}-linux-x86_64.tar")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-aarch64.tar")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-x86_64.tar")
noextract=("${pkgname%-bin}-${pkgver}-${CARCH}.tar")
-sha256sums_aarch64=('9472215126987c8508bf8e595429d1eba1c6a9041e2eded6ae24736070036e36')
-sha256sums_x86_64=('4ac735a698fca2cfab0461e466a9ca33e3c722e77a5ee31b6cef9bc2d0db5909')
+sha256sums_aarch64=('63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379')
+sha256sums_x86_64=('616ab5cfd458cb3ba1a8fea163443e686173a6312d806e42a08e920adcfce97b')
package() {
install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.tar" -C "${pkgdir}/opt/${pkgname%-bin}" --gname root --uname root