summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-15 18:30:14 +0800
committerzxp198210052024-01-15 18:30:14 +0800
commit743b5eb3e9bd1a2da2229270e4970c15eacb3e4f (patch)
tree55f75ee5f43e647b64b4a0cba18386b1427c9164
parentb9aef2df794fde772c5677243ef57183f4e93cb4 (diff)
downloadaur-743b5eb3e9bd1a2da2229270e4970c15eacb3e4f.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--bluebubbles.sh6
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08d9eff83f24..54a9f46bd18b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
pkgver = 1.12.7
- pkgrel = 1
+ pkgrel = 2
url = https://bluebubbles.app/
arch = aarch64
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = bluebubbles-bin
provides = bluebubbles=1.12.7
conflicts = bluebubbles
source = bluebubbles.sh
- sha256sums = 4f890079812e5c20c11a589f3c71a11b091a77c8c836302a0563b03f7c44b7ea
+ sha256sums = 12abd34519533d6c13c77216ea40791d5bdb63edad389b41cfe0a264b0ad4e77
source_aarch64 = bluebubbles-1.12.7-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-aarch64.tar
sha256sums_aarch64 = 6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b
source_x86_64 = bluebubbles-1.12.7-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-x86_64.tar
diff --git a/PKGBUILD b/PKGBUILD
index acc0859bbf9f..d6643505dbf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=bluebubbles-bin
_pkgname=BlueBubbles
pkgver=1.12.7
_subver=2B61
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=(
'aarch64'
@@ -35,11 +35,14 @@ makedepends=(
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-aarch64.tar")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-x86_64.tar")
source=("${pkgname%-bin}.sh")
-sha256sums=('4f890079812e5c20c11a589f3c71a11b091a77c8c836302a0563b03f7c44b7ea')
+sha256sums=('12abd34519533d6c13c77216ea40791d5bdb63edad389b41cfe0a264b0ad4e77')
sha256sums_aarch64=('6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b')
sha256sums_x86_64=('8c0c3487062cb7546b5208b85cbda6794251e046256f9c422fee1ce067ffc34c')
build() {
- gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin}"
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${pkgname%-bin}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/bluebubbles.sh b/bluebubbles.sh
index 57b9efaf6447..c9beccd772b0 100644
--- a/bluebubbles.sh
+++ b/bluebubbles.sh
@@ -1,8 +1,8 @@
#!/bin/bash
set -e
-_APPNAME=bluebubbles
-_APPDIR="/opt/${_APPNAME}"
+_APPDIR=/opt/@appname@
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_APPDIR}/${_APPNAME}" %U "$@" \ No newline at end of file
+exec "${_RUNNAME}" "$@" | exit \ No newline at end of file