summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 11:54:29 +0800
committerzxp198210052024-02-26 11:54:29 +0800
commita8f60a3a94fef5aecae1157f125ba507d978e33a (patch)
tree0fad1199704da312068918816adf5f3b5df7db51
parent743b5eb3e9bd1a2da2229270e4970c15eacb3e4f (diff)
downloadaur-a8f60a3a94fef5aecae1157f125ba507d978e33a.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--bluebubbles.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54a9f46bd18b..7bb6f7359f94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
pkgver = 1.12.7
- pkgrel = 2
+ pkgrel = 3
url = https://bluebubbles.app/
arch = aarch64
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = gendesk
depends = libepoxy
depends = webkit2gtk-4.1
@@ -23,7 +23,7 @@ pkgbase = bluebubbles-bin
provides = bluebubbles=1.12.7
conflicts = bluebubbles
source = bluebubbles.sh
- sha256sums = 12abd34519533d6c13c77216ea40791d5bdb63edad389b41cfe0a264b0ad4e77
+ sha256sums = 984792e5e81a0f8f076fdfd20bdc72c152664346b099312114ecb1e4fe2fcb83
source_aarch64 = bluebubbles-1.12.7-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-aarch64.tar
sha256sums_aarch64 = 6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b
source_x86_64 = bluebubbles-1.12.7-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-x86_64.tar
diff --git a/PKGBUILD b/PKGBUILD
index d6643505dbf8..3a24aa134c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=bluebubbles-bin
_pkgname=BlueBubbles
pkgver=1.12.7
_subver=2B61
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=(
'aarch64'
@@ -11,7 +11,7 @@ arch=(
)
url="https://bluebubbles.app/"
_ghurl="https://github.com/BlueBubblesApp/bluebubbles-app"
-license=('Apache')
+license=('Apache-2.0')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -35,14 +35,14 @@ makedepends=(
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-aarch64.tar")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-x86_64.tar")
source=("${pkgname%-bin}.sh")
-sha256sums=('12abd34519533d6c13c77216ea40791d5bdb63edad389b41cfe0a264b0ad4e77')
+sha256sums=('984792e5e81a0f8f076fdfd20bdc72c152664346b099312114ecb1e4fe2fcb83')
sha256sums_aarch64=('6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b')
sha256sums_x86_64=('8c0c3487062cb7546b5208b85cbda6794251e046256f9c422fee1ce067ffc34c')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${pkgname%-bin}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+ gendesk -f -n -q --categories="Network" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/bluebubbles.sh b/bluebubbles.sh
index c9beccd772b0..27a779466922 100644
--- a/bluebubbles.sh
+++ b/bluebubbles.sh
@@ -5,4 +5,4 @@ _RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_RUNNAME}" "$@" | exit \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file