summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-05 05:25:51 +0800
committerzxp198210052023-12-05 05:25:51 +0800
commitb9aef2df794fde772c5677243ef57183f4e93cb4 (patch)
treea1dfa7aa2e02d6276bb19f0a60f4dd8354dbb24d
parentcab3a390d381ccd5ed3c827aae9e13c6aa3d4ce6 (diff)
downloadaur-b9aef2df794fde772c5677243ef57183f4e93cb4.tar.gz
update to 1.12.7
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--bluebubbles.sh8
3 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 627ab3c6dc9a..08d9eff83f24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
- pkgver = 1.12.6
+ pkgver = 1.12.7
pkgrel = 1
url = https://bluebubbles.app/
arch = aarch64
@@ -20,11 +20,13 @@ pkgbase = bluebubbles-bin
depends = libappindicator-gtk3
depends = gtk3
depends = libsoup3
- provides = bluebubbles=1.12.6
+ provides = bluebubbles=1.12.7
conflicts = bluebubbles
- source_aarch64 = bluebubbles-1.12.6-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.6%2B60/bluebubbles-linux-aarch64.tar
- sha256sums_aarch64 = 374710f68ee71e131346aee9d29282fe1fd21d6f4d0c545463133ea3bce55047
- source_x86_64 = bluebubbles-1.12.6-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.6%2B60/bluebubbles-linux-x86_64.tar
- sha256sums_x86_64 = 916ea47eaab1c02d7324150f0bb46479655c23b8fcf070faee38cbb75e97ad61
+ source = bluebubbles.sh
+ sha256sums = 4f890079812e5c20c11a589f3c71a11b091a77c8c836302a0563b03f7c44b7ea
+ source_aarch64 = bluebubbles-1.12.7-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-aarch64.tar
+ sha256sums_aarch64 = 6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b
+ source_x86_64 = bluebubbles-1.12.7-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.7%2B61/bluebubbles-linux-x86_64.tar
+ sha256sums_x86_64 = 8c0c3487062cb7546b5208b85cbda6794251e046256f9c422fee1ce067ffc34c
pkgname = bluebubbles-bin
diff --git a/PKGBUILD b/PKGBUILD
index e4a79cfde320..acc0859bbf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluebubbles-bin
_pkgname=BlueBubbles
-pkgver=1.12.6
+pkgver=1.12.7
+_subver=2B61
pkgrel=1
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=(
@@ -31,19 +32,21 @@ depends=(
makedepends=(
'gendesk'
)
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_ghurl}/releases/download/v${pkgver}%2B60/${pkgname%-bin}-linux-aarch64.tar")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_ghurl}/releases/download/v${pkgver}%2B60/${pkgname%-bin}-linux-x86_64.tar")
-sha256sums_aarch64=('374710f68ee71e131346aee9d29282fe1fd21d6f4d0c545463133ea3bce55047')
-sha256sums_x86_64=('916ea47eaab1c02d7324150f0bb46479655c23b8fcf070faee38cbb75e97ad61')
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-aarch64.tar")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_ghurl}/releases/download/v${pkgver}%${_subver}/${pkgname%-bin}-linux-x86_64.tar")
+source=("${pkgname%-bin}.sh")
+sha256sums=('4f890079812e5c20c11a589f3c71a11b091a77c8c836302a0563b03f7c44b7ea')
+sha256sums_aarch64=('6df20701f6a7087d362f0b27e294929d259896bd2f36908053d00cf713e7a08b')
+sha256sums_x86_64=('8c0c3487062cb7546b5208b85cbda6794251e046256f9c422fee1ce067ffc34c')
build() {
- gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+ gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin}"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin,usr/lib}
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/lib}
cp -r "${srcdir}/"{data,lib} "${pkgdir}/opt/${pkgname%-bin}"
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/data/flutter_assets/assets/icon/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/opt/${pkgname%-bin}"
- ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
ln -sf "/usr/lib/libmpv.so" "${pkgdir}/usr/lib/libmpv.so.1"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/bluebubbles.sh b/bluebubbles.sh
new file mode 100644
index 000000000000..57b9efaf6447
--- /dev/null
+++ b/bluebubbles.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+set -e
+_APPNAME=bluebubbles
+_APPDIR="/opt/${_APPNAME}"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+cd "${_APPDIR}"
+exec "${_APPDIR}/${_APPNAME}" %U "$@" \ No newline at end of file