summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-02 20:08:06 +0800
committerzxp198210052023-09-02 20:08:06 +0800
commitbc6f2c738367250542bdaa41820929e48ac55951 (patch)
treec21bf8aa1442fa6120c5b277dfc77ee5ff739828
parent6b6c185511de64e3e44b0ad611ee0002d55722b2 (diff)
downloadaur-bc6f2c738367250542bdaa41820929e48ac55951.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2be66652871e..4517751aa2c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluebubbles-bin
pkgdesc = A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!
pkgver = 1.12.4
- pkgrel = 1
+ pkgrel = 2
url = https://bluebubbles.app/
arch = aarch64
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = bluebubbles-bin
depends = at-spi2-core
depends = gdk-pixbuf2
depends = cairo
+ depends = mpv
depends = harfbuzz
depends = glibc
depends = pango
@@ -23,7 +24,6 @@ pkgbase = bluebubbles-bin
depends = gtk3
provides = bluebubbles=1.12.4
conflicts = bluebubbles
- noextract = bluebubbles-1.12.4-x86_64.tar
source_aarch64 = bluebubbles-1.12.4-aarch64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.4%2B58/bluebubbles-linux-aarch64.tar
sha256sums_aarch64 = 63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379
source_x86_64 = bluebubbles-1.12.4-x86_64.tar::https://github.com/BlueBubblesApp/bluebubbles-app/releases/download/v1.12.4%2B58/bluebubbles-linux-x86_64.tar
diff --git a/PKGBUILD b/PKGBUILD
index b3948e13057e..ba1bf3f027e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluebubbles-bin
+_pkgname=BlueBubbles
pkgver=1.12.4
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
arch=('aarch64' 'x86_64')
url="https://bluebubbles.app/"
@@ -9,18 +10,23 @@ _githuburl="https://github.com/BlueBubblesApp/bluebubbles-app"
license=('Apache')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('glib2' 'libepoxy' 'vlc' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' \
+depends=('glib2' 'libepoxy' 'vlc' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' 'mpv' \
'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3')
makedepends=('gendesk')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-aarch64.tar")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-x86_64.tar")
-noextract=("${pkgname%-bin}-${pkgver}-${CARCH}.tar")
sha256sums_aarch64=('63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379')
sha256sums_x86_64=('616ab5cfd458cb3ba1a8fea163443e686173a6312d806e42a08e920adcfce97b')
+prepare() {
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+}
package() {
- install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.tar" -C "${pkgdir}/opt/${pkgname%-bin}" --gname root --uname root
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin,usr/lib}
+ cp -r "${srcdir}/"{data,lib} "${pkgdir}/opt/${pkgname%-bin}"
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/data/flutter_assets/assets/icon/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ ln -sf "/usr/lib/libmpv.so" "${pkgdir}/usr/lib/libmpv.so.1"
gendesk -f -n --icon "${pkgname%-bin}" --categories "Network" --name "BlueBubbles" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file