summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Fortney2020-11-12 01:39:33 -0500
committerMaxwell Fortney2020-11-12 01:39:33 -0500
commit090be90763e236ffbbda1ce7d7f9d3c969bf929c (patch)
tree7f7c5e238e43f876796de0b959631c269de1e8d9
downloadaur-090be90763e236ffbbda1ce7d7f9d3c969bf929c.tar.gz
Initial commit of version 1.0.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..228e530d56c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bluebubbles-desktop-app
+ pkgdesc = Cross-platform iMessage client
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://bluebubbles.app/
+ arch = x86_64
+ license = unknown
+ optdepends = noto-fonts-emoji
+ source = bluebubbles-desktop-app-1.0.2.deb::https://github.com/BlueBubblesApp/BlueBubbles-Desktop-App/releases/download/1.0.2/bluebubbles-desktop-app-1.0.2.deb
+ sha256sums = 5850b62567f600cb5cbf4d51a094fe385672a4029585a12efdd47d925d22eb25
+
+pkgname = bluebubbles-desktop-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9555e6209310
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Maxwell Fortney <maxwellfortney@gmail.com>
+pkgname=bluebubbles-desktop-app
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Cross-platform iMessage client"
+arch=('x86_64')
+url="https://bluebubbles.app/"
+license=('unknown')
+optdepends=('noto-fonts-emoji')
+changelog=
+sha256sums=('5850b62567f600cb5cbf4d51a094fe385672a4029585a12efdd47d925d22eb25')
+source=("$pkgname-$pkgver.deb::https://github.com/BlueBubblesApp/BlueBubbles-Desktop-App/releases/download/$pkgver/$pkgname-$pkgver.deb")
+
+package() {
+ #Get the data from the deb
+ tar -xvf data.tar.xz
+
+ # Install the main files.
+ install -d "${pkgdir}/opt/BlueBubbles"
+ cp -a "./opt/BlueBubbles/." "${pkgdir}/opt/BlueBubbles"
+
+ # Install desktop shortcut
+ install -Dm644 "./usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Create symbolic link to the icon
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/opt/BlueBubbles/resources/resources/icon1024.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}