summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Fortney2020-11-12 02:18:24 -0500
committerMaxwell Fortney2020-11-12 02:18:24 -0500
commit91476ceddcfb62ad45dd64eb67a694f4e0636b1d (patch)
tree110723474a947ae1f1ad8b3428cf6af370f8f6e3
parent090be90763e236ffbbda1ce7d7f9d3c969bf929c (diff)
downloadaur-91476ceddcfb62ad45dd64eb67a694f4e0636b1d.tar.gz
Adds bin to usr/bin in order to allow runnign from terminal, hopefully fixes tray icon temporarily
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 228e530d56c8..8eee90e8d2d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,3 +11,16 @@ pkgbase = bluebubbles-desktop-app
pkgname = bluebubbles-desktop-app
+pkgbase = bluebubbles-desktop-app
+ pkgdesc = Open source cross-platform iMessage client
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://bluebubbles.app/
+ arch = x86_64
+ license = unknown
+ optdepends = noto-fonts-emoji
+ source = bluebubbles-desktop-app-1.0.2.deb::https://github.com/BlueBubblesApp/BlueBubbles-Desktop-App/releases/download/1.0.2/bluebubbles-desktop-app-1.0.2.deb
+ sha256sums = 5850b62567f600cb5cbf4d51a094fe385672a4029585a12efdd47d925d22eb25
+
+pkgname = bluebubbles-desktop-app
+
diff --git a/PKGBUILD b/PKGBUILD
index 9555e6209310..18907fa75947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bluebubbles-desktop-app
pkgver=1.0.2
pkgrel=1
-pkgdesc="Cross-platform iMessage client"
+pkgdesc="Open source cross-platform iMessage client"
arch=('x86_64')
url="https://bluebubbles.app/"
license=('unknown')
@@ -19,10 +19,15 @@ package() {
install -d "${pkgdir}/opt/BlueBubbles"
cp -a "./opt/BlueBubbles/." "${pkgdir}/opt/BlueBubbles"
- # Install desktop shortcut
- install -Dm644 "./usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ # Install desktop shortcut and bin
+ install -Dm644 "./usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/BlueBubbles/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# Create symbolic link to the icon
install -d "${pkgdir}/usr/share/pixmaps"
ln -s "/opt/BlueBubbles/resources/resources/icon1024.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # Create tray icon to temporarily fix close button bug
+ ln -s "/opt/BlueBubbles/resources/resources/icon1024.png" "${pkgdir}/opt/BlueBubbles/resources/resources/67bdc3519553d5530a5ee09ba21f7602.png"
}