summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornomisge2021-05-02 19:26:22 +0200
committernomisge2021-05-02 19:26:22 +0200
commit8afce7828fd216be9e6215138c779f5f28c2d5ae (patch)
tree374e60d7598a85a37780fe3f5b73e34263015549
parentededa7182352fc55d5e4c31c18d0d9e1473df360 (diff)
downloadaur-8afce7828fd216be9e6215138c779f5f28c2d5ae.tar.gz
New Version upstream
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--bluej1
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d468bfb912e1..61a8bbd2fd20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluej
pkgdesc = A free Java Development Environment designed for beginners, used by millions worlwide.
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
url = https://www.bluej.org
arch = any
@@ -11,17 +11,18 @@ pkgbase = bluej
license = LGPL2.1
license = MIT
license = custom
+ depends = gtk2
depends = archlinux-java-run
depends = java-runtime=11
depends = java-environment=11
depends = java11-openjfx
- noextract = BlueJ-linux-500.deb
- source = https://www.bluej.org/download/files/BlueJ-linux-500.deb
+ noextract = BlueJ-linux-501.deb
+ source = https://www.bluej.org/download/files/BlueJ-linux-501.deb
source = bluej
source = bluej.desktop
source = bluej.xml
- sha256sums = 53cd4521febb426ffcebe840f625021edeb5771899b139247aaba55637edebfd
- sha256sums = 6b11a4e49f92d636ac170c95de8a2ae02ad94031d403cbd23c626ffa7f0ac068
+ sha256sums = 2a1361276c6cc35836c9e9b03fa350989be4e1cc5901040d3c4501b8bb28e6a3
+ sha256sums = c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8
sha256sums = a845f3997ce91cfb1eeb882f4a6e1e4408b7a7d7c2e164495b5a077bdf353e7f
sha256sums = e05453bd791b34ab6cfd6b67250dd18210f47505344b7980ad28bf922c014772
diff --git a/PKGBUILD b/PKGBUILD
index d6dd0ef7500c..a6b6e4b788bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,20 @@
# Contributor: zerathidune <zerathidune @ gmail . com>
pkgname=bluej
-pkgver=5.0.0
+pkgver=5.0.1
pkgrel=1
pkgdesc="A free Java Development Environment designed for beginners, used by millions worlwide."
arch=('any')
url="https://www.${pkgname}.org"
license=('GPL2' 'Apache' 'BSD' 'CPL' 'LGPL2.1' 'MIT' 'custom')
-depends=('archlinux-java-run' 'java-runtime=11' 'java-environment=11' 'java11-openjfx')
+depends=('gtk2' 'archlinux-java-run' 'java-runtime=11' 'java-environment=11' 'java11-openjfx')
source=("https://www.${pkgname}.org/download/files/BlueJ-linux-${pkgver//.}.deb"
"${pkgname}"
"${pkgname}.desktop"
"${pkgname}.xml")
noextract=("BlueJ-linux-${pkgver//.}.deb")
-sha256sums=('53cd4521febb426ffcebe840f625021edeb5771899b139247aaba55637edebfd'
- '6b11a4e49f92d636ac170c95de8a2ae02ad94031d403cbd23c626ffa7f0ac068'
+sha256sums=('2a1361276c6cc35836c9e9b03fa350989be4e1cc5901040d3c4501b8bb28e6a3'
+ 'c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8'
'a845f3997ce91cfb1eeb882f4a6e1e4408b7a7d7c2e164495b5a077bdf353e7f'
'e05453bd791b34ab6cfd6b67250dd18210f47505344b7980ad28bf922c014772')
diff --git a/bluej b/bluej
index 24a48c431dd3..98933a507a27 100644
--- a/bluej
+++ b/bluej
@@ -19,6 +19,7 @@ JFXRTOPT="-javafxpath=$JAVAFXPATH"
JFXRTOPT2="-javafxjars=$JAVAFXJARS"
archlinux-java-run -a 11 -b 11 -- \
+ -Djdk.gtk.version=2 \
-Dawt.useSystemAAFontSettings=on -Xmx512M \
-cp "$CP" bluej.Boot ${JFXRTOPT:+"$JFXRTOPT"} ${JFXRTOPT2:+"$JFXRTOPT2"} \
"$@"