summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornomisge2022-09-21 18:16:41 +0200
committernomisge2022-09-21 18:16:41 +0200
commita19055b3d041f9bde663f52cd0a38f42a84780cf (patch)
treecb7bc4bfe34c167cbbc22e02d0656eececd68a9d
parent2863e212651b7d520be72c0d9ba95842f8dca35c (diff)
downloadaur-a19055b3d041f9bde663f52cd0a38f42a84780cf.tar.gz
Update version, finally with java 17
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
-rw-r--r--bluej8
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbc8b065d806..07a72b84baa1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluej
pkgdesc = A free Java Development Environment designed for beginners, used by millions worlwide.
- pkgver = 5.0.3
+ pkgver = 5.1.0
pkgrel = 1
url = https://www.bluej.org
arch = any
@@ -12,16 +12,16 @@ pkgbase = bluej
license = custom
depends = gtk2
depends = archlinux-java-run
- depends = java-runtime=11
- depends = java-environment=11
- depends = java11-openjfx
- noextract = BlueJ-linux-503.deb
- source = https://www.bluej.org/download/files/BlueJ-linux-503.deb
+ depends = java-runtime=17
+ depends = java-environment=17
+ depends = java17-openjfx
+ noextract = BlueJ-linux-510.deb
+ source = https://www.bluej.org/download/files/BlueJ-linux-510.deb
source = bluej
source = bluej.desktop
source = bluej.xml
- sha256sums = 39aaea9a9b7165cef110461ea0256a1d7900bdfcdf498c799d4a7f8963f2a2ac
- sha256sums = c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8
+ sha256sums = b4e6f5e7053d3a352dd03f25fc991a1988fce0bec75781549d0401e5c440c46d
+ sha256sums = fa1e1b8524e32ec4151565b901411a08458855e4a8f2a77ae77827af86db85a9
sha256sums = a845f3997ce91cfb1eeb882f4a6e1e4408b7a7d7c2e164495b5a077bdf353e7f
sha256sums = e05453bd791b34ab6cfd6b67250dd18210f47505344b7980ad28bf922c014772
diff --git a/PKGBUILD b/PKGBUILD
index f668193bff6d..4c8adf1565de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,20 @@
# Contributor: zerathidune <zerathidune @ gmail . com>
pkgname=bluej
-pkgver=5.0.3
+pkgver=5.1.0
pkgrel=1
pkgdesc="A free Java Development Environment designed for beginners, used by millions worlwide."
arch=('any')
url="https://www.${pkgname}.org"
license=('GPL2' 'Apache' 'BSD' 'CDDL' 'CPL' 'custom')
-depends=('gtk2' 'archlinux-java-run' 'java-runtime=11' 'java-environment=11' 'java11-openjfx')
+depends=('gtk2' 'archlinux-java-run' 'java-runtime=17' 'java-environment=17' 'java17-openjfx')
source=("https://www.${pkgname}.org/download/files/BlueJ-linux-${pkgver//.}.deb"
"${pkgname}"
"${pkgname}.desktop"
"${pkgname}.xml")
noextract=("BlueJ-linux-${pkgver//.}.deb")
-sha256sums=('39aaea9a9b7165cef110461ea0256a1d7900bdfcdf498c799d4a7f8963f2a2ac'
- 'c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8'
+sha256sums=('b4e6f5e7053d3a352dd03f25fc991a1988fce0bec75781549d0401e5c440c46d'
+ 'fa1e1b8524e32ec4151565b901411a08458855e4a8f2a77ae77827af86db85a9'
'a845f3997ce91cfb1eeb882f4a6e1e4408b7a7d7c2e164495b5a077bdf353e7f'
'e05453bd791b34ab6cfd6b67250dd18210f47505344b7980ad28bf922c014772')
diff --git a/bluej b/bluej
index 98933a507a27..12b556deafa1 100644
--- a/bluej
+++ b/bluej
@@ -1,8 +1,8 @@
#!/bin/sh
-if [ -e /usr/lib/jvm/java-11-openjfx/lib ]; then
- JAVAFXPATH=/usr/lib/jvm/java-11-openjfx
+if [ -e /usr/lib/jvm/java-17-openjfx/lib ]; then
+ JAVAFXPATH=/usr/lib/jvm/java-17-openjfx
else
- JAVAFXPATH=/usr/lib/jvm/java-11-openjdk
+ JAVAFXPATH=/usr/lib/jvm/java-17-openjdk
fi
CP="/opt/bluej/bluej.jar"
@@ -18,7 +18,7 @@ CP="$CP:$JAVAFXJARS"
JFXRTOPT="-javafxpath=$JAVAFXPATH"
JFXRTOPT2="-javafxjars=$JAVAFXJARS"
-archlinux-java-run -a 11 -b 11 -- \
+archlinux-java-run -a 17 -b 17 -- \
-Djdk.gtk.version=2 \
-Dawt.useSystemAAFontSettings=on -Xmx512M \
-cp "$CP" bluej.Boot ${JFXRTOPT:+"$JFXRTOPT"} ${JFXRTOPT2:+"$JFXRTOPT2"} \