summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Bunton2016-11-09 17:55:50 +1100
committerJames Bunton2016-11-09 17:55:50 +1100
commit0e97e403b32fdc7ab038573d5dd7cd79bef720b4 (patch)
tree9d25774cd43f0234882067b6d33e46309e0fee7b
parente29d3161b1ad247ecab7503cf9af4da8748c322c (diff)
downloadaur-0e97e403b32fdc7ab038573d5dd7cd79bef720b4.tar.gz
Switch to Bluejeans app
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
-rw-r--r--bluejeans.install17
3 files changed, 51 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d67aacc2a005..8203e3e2e764 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Sun Jul 24 08:21:15 UTC 2016
+# Wed Nov 9 06:55:31 UTC 2016
pkgbase = bluejeans
- pkgdesc = BlueJeans browser plugin
- pkgver = 2.160.66.8
+ pkgdesc = BlueJeans app
+ pkgver = 1.18.15
pkgrel = 1
- url = http://www.bluejeans.com/
+ url = https://www.bluejeans.com
+ install = bluejeans.install
arch = x86_64
license = Proprietary
- conflicts = bjnplugin
- source = https://swdl.bluejeans.com/skinny/rbjnplugin_2.160.66.8-1_amd64.deb
- sha1sums = 9ac0b9851218d8ab5ff2a88876b98c3b7c9d7908
+ makedepends = rpmextract
+ source = http://swdl.bluejeans.com/desktop/linux/1.18/1.18.15/bluejeans-1.18.15.x86_64.rpm
+ sha256sums = fb87b6e20c0893485dc3bb79cb03161d7e79a087467fd51e86dfbd3250ad71ef
pkgname = bluejeans
diff --git a/PKGBUILD b/PKGBUILD
index f782827281a2..a29a9b208c23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
# Maintainer: James Bunton <jamesbunton@delx.net.au>
-# Contributor: David Mason <djmason@gmail.com>
-# Contributor: Wijnand Modderman-Lenstra <maze@maze.io>
# The latest version can be found like this:
-# $ curl -s http://bluejeans.com/downloads | grep 'bjnplugin.*\.deb'
+# $ curl -s https://bluejeans.com/downloads | grep 'desktop/linux'
pkgname=bluejeans
-pkgver=2.160.66.8
+pkgver=1.18.15
pkgrel=1
-pkgdesc="BlueJeans browser plugin"
+pkgdesc="BlueJeans app"
arch=('x86_64')
-url="http://www.bluejeans.com/"
+url="https://www.bluejeans.com"
license=('Proprietary')
groups=()
-conflicts=(bjnplugin)
depends=()
-source=(
- https://swdl.bluejeans.com/skinny/rbjnplugin_${pkgver}-1_amd64.deb
-)
-sha1sums=('9ac0b9851218d8ab5ff2a88876b98c3b7c9d7908')
+makedepends=('rpmextract')
+install=bluejeans.install
+source=(http://swdl.bluejeans.com/desktop/linux/${pkgver%.*}/${pkgver}/bluejeans-${pkgver}.x86_64.rpm)
+sha256sums=('fb87b6e20c0893485dc3bb79cb03161d7e79a087467fd51e86dfbd3250ad71ef')
package() {
- ar x rbjnplugin_${pkgver}-${pkgrel}_amd64.deb "${pkgdir}"
- tar xf data.tar.gz -C "${pkgdir}"
+ # extract rpm
+ rpmextract.sh "bluejeans-${pkgver}.x86_64.rpm"
+
+ # add bluejeans wrapper to /usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
+ chmod +x "opt/bluejeans/bluejeans"
+ ln -nsf "/opt/bluejeans/bluejeans" "${pkgdir}/usr/bin/bluejeans"
+
+ # install desktop file and icons
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ mv "opt/bluejeans/bluejeans.desktop" "${pkgdir}/usr/share/applications/"
+ mv "opt/bluejeans/icons" "${pkgdir}/usr/share/"
+
+ # hack for libudev.so.0
+ ln -nsf "/usr/lib/libudev.so.1" "opt/bluejeans/libudev.so.0"
+
+ # put the rest in /opt
+ mv "opt" "${pkgdir}"
}
diff --git a/bluejeans.install b/bluejeans.install
new file mode 100644
index 000000000000..17d6cbf3e20d
--- /dev/null
+++ b/bluejeans.install
@@ -0,0 +1,17 @@
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Bluejeans is no longer supporting their browser plugin."
+ note "This package has now switched to the Bluejeans app instead."
+}
+
+post_upgrade() {
+ post_install
+}