summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-12 15:11:44 +0800
committerzxp198210052024-03-12 15:11:44 +0800
commitdae8e689e256a822777255b06a32676a11738f4b (patch)
tree00967ed7d21db74e96962832cccf3257013e9129
downloadaur-dae8e689e256a822777255b06a32676a11738f4b.tar.gz
update to 1.1.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
-rw-r--r--blueknight.sh16
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91864108d62a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blueknight-bin
+ pkgdesc = A Minecraft Launcher made with electron, that uses the Modrinth api to make installing mods as easy as possible.
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/KartoffelChipss/blueknight
+ arch = x86_64
+ license = GPL-3.0-only
+ depends = electron28
+ provides = blueknight=1.1.2
+ conflicts = blueknight
+ source = blueknight-1.1.2.deb::https://github.com/KartoffelChipss/blueknight/releases/download/v1.1.2-beta/blueknight-launcher-deb-1.1.2.deb
+ source = blueknight.sh
+ sha256sums = b20ad73332f37aa956c0656fb033848cfe3985a61866600c1f6092a19ba7c1b6
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+
+pkgname = blueknight-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ec91a3ddf55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=blueknight-bin
+_pkgname=BlueKnight
+pkgver=1.1.2
+_electronversion=28
+pkgrel=1
+pkgdesc="A Minecraft Launcher made with electron, that uses the Modrinth api to make installing mods as easy as possible."
+arch=('x86_64')
+url="https://github.com/KartoffelChipss/blueknight"
+license=('GPL-3.0-only')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
+depends=(
+ "electron${_electronversion}"
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}-beta/${pkgname%-bin}-launcher-deb-${pkgver}.deb"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('b20ad73332f37aa956c0656fb033848cfe3985a61866600c1f6092a19ba7c1b6'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ bsdtar -xf "${srcdir}/data."*
+ sed "s|\"\/opt\/${_pkgname} Launcher\/${pkgname%-bin}\"|${pkgname%-bin}|g;s|Utility|Game|g" \
+ -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname} Launcher/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+} \ No newline at end of file
diff --git a/blueknight.sh b/blueknight.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/blueknight.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file