summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlisson Lauffer2022-08-15 18:12:04 -0300
committerAlisson Lauffer2022-08-15 18:12:04 -0300
commitffe37d4e29b56331b9218bd027c06461f0af9ab4 (patch)
tree598bc25f080c60642e0fb4fddd53ff1ab2574056
parenta152a99687fc2c7dac529b0b8e081a8f3958ed41 (diff)
downloadaur-ffe37d4e29b56331b9218bd027c06461f0af9ab4.tar.gz
Respect Electron flags from ~/.config/bluemail-flags.conf
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--bluemail.sh11
3 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80e877c9bc5c..5a86776824b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluemail
pkgdesc = BlueMail is a free, secure, universal email app, capable of managing an unlimited number of mail accounts
pkgver = 1.131.13
- pkgrel = 1
+ pkgrel = 2
url = https://www.bluemail.me
arch = x86_64
license = custom
@@ -12,12 +12,12 @@ pkgbase = bluemail
depends = libxtst
depends = nss
depends = libxss
- provides = bluemail
- conflicts = bluemail-bin
options = !strip
source = LICENSE
source = bluemail-1.131.13.snap::https://api.snapcraft.io/api/v1/snaps/download/ZVlj0qw0GOFd5JgTfL8kk2Y5eIG1IpiH_135.snap
+ source = bluemail.sh
sha512sums = 546994dbf25972659db6130402926020fdfc763b3f41580d812aeb785824218bae1204babe99af51ad91fd758ad0e7f4d0636a00e9130ce13fc6ebb90540e9dc
sha512sums = 9c0a1b56290e0f964dac8bda4f376d36ebb22f2ffebbf0b1e87a8736158cf58468bee75459535d3368168f1eaa96f20620a78acdd2db21bc218f2cbeb75c06a1
+ sha512sums = 4f435819d7cd4db345c92858619618a693764dbab8fe9bec8155af9b2236f0e8a671a724fee06773e478bae2924694d0c2bf9a53ae2649fb5964b8b6cc739fba
pkgname = bluemail
diff --git a/PKGBUILD b/PKGBUILD
index 2ad1519596fc..385c520e644c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Alisson Lauffer <alissonvitortc@gmail.com>
# Contributor: TBK <aur at jjtc dot eu>
+# Contributor: D. Can Celasun <can[at]dcc[dot]im>
pkgname=bluemail
pkgver=1.131.13
-pkgrel=1
+pkgrel=2
pkgdesc="BlueMail is a free, secure, universal email app, capable of managing an unlimited number of mail accounts"
arch=('x86_64')
url="https://www.bluemail.me"
license=('custom')
-conflicts=('bluemail-bin')
-provides=('bluemail')
depends=('libnotify' 'libappindicator-gtk3' 'libxtst' 'nss' 'libxss')
makedepends=('squashfs-tools' 'imagemagick')
@@ -20,10 +19,12 @@ options=(!strip)
# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/bluemail | jq '.download_url' -r
# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/bluemail | jq '.version' -r
source=('LICENSE'
- "${pkgname}-${pkgver}.snap::https://api.snapcraft.io/api/v1/snaps/download/ZVlj0qw0GOFd5JgTfL8kk2Y5eIG1IpiH_135.snap")
+ "${pkgname}-${pkgver}.snap::https://api.snapcraft.io/api/v1/snaps/download/ZVlj0qw0GOFd5JgTfL8kk2Y5eIG1IpiH_135.snap"
+ "${pkgname}.sh")
sha512sums=('546994dbf25972659db6130402926020fdfc763b3f41580d812aeb785824218bae1204babe99af51ad91fd758ad0e7f4d0636a00e9130ce13fc6ebb90540e9dc'
- '9c0a1b56290e0f964dac8bda4f376d36ebb22f2ffebbf0b1e87a8736158cf58468bee75459535d3368168f1eaa96f20620a78acdd2db21bc218f2cbeb75c06a1')
+ '9c0a1b56290e0f964dac8bda4f376d36ebb22f2ffebbf0b1e87a8736158cf58468bee75459535d3368168f1eaa96f20620a78acdd2db21bc218f2cbeb75c06a1'
+ '4f435819d7cd4db345c92858619618a693764dbab8fe9bec8155af9b2236f0e8a671a724fee06773e478bae2924694d0c2bf9a53ae2649fb5964b8b6cc739fba')
package() {
mkdir -p "${pkgdir}/opt"
@@ -31,8 +32,11 @@ package() {
unsquashfs -f -d "${pkgdir}/opt/bluemail" "${pkgname}-${pkgver}.snap"
+ # Fix too open folder permission
chmod 755 "${pkgdir}/opt/bluemail"
- ln -sf /opt/bluemail/bluemail "${pkgdir}/usr/bin/bluemail"
+
+ # Install launcher
+ install -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/bluemail"
# Fix and install desktop icons
for size in 22 24 32 48 64 128 256 512; do
diff --git a/bluemail.sh b/bluemail.sh
new file mode 100644
index 000000000000..d3550f8ec0a8
--- /dev/null
+++ b/bluemail.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+
+XDG_CONFIG_HOME=${XDG_CONFIG_HOME:-~/.config}
+
+# Allow users to override command-line options
+if [[ -f $XDG_CONFIG_HOME/bluemail-flags.conf ]]; then
+ BLUEMAIL_USER_FLAGS="$(sed 's/#.*//' $XDG_CONFIG_HOME/bluemail-flags.conf | tr '\n' ' ')"
+fi
+
+# Launch
+exec /opt/bluemail/bluemail $BLUEMAIL_USER_FLAGS "$@"