summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-12-23 11:21:30 +0100
committerMichael Straube2016-12-23 11:21:30 +0100
commit5256d0ba5de566e1dc211c5427d632c9361bdeae (patch)
tree61280d0d96a5c2d1d765a14298cdd4e9e7768835
downloadaur-5256d0ba5de566e1dc211c5427d632c9361bdeae.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--makefile.patch10
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dde8d3225add
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bluemindo
+ pkgdesc = Ergonomic and modern music player designed for audiophiles
+ pkgver = 1.0rc1
+ pkgrel = 1
+ url = http://bluemindo.codingteam.net
+ arch = any
+ license = GPL3
+ depends = gst-python
+ depends = python-dbus
+ depends = python-beautifulsoup4
+ depends = python-pytaglib
+ source = https://codingteam.net/project/bluemindo/download/file/bluemindo-1.0rc1.tar.gz
+ source = makefile.patch
+ sha256sums = e405c881feeb43f8126988403e1c1008ee5341c8faae90d5e671d9075c89fe5c
+ sha256sums = 3f8758bd2255966af796937902e1ff5064df3f34283172eaee8b28d855fb0747
+
+pkgname = bluemindo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..595deb07518e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michael Straube <straubem@gmx.de>
+
+pkgname=bluemindo
+pkgver=1.0rc1
+pkgrel=1
+pkgdesc='Ergonomic and modern music player designed for audiophiles'
+arch=('any')
+url='http://bluemindo.codingteam.net'
+license=('GPL3')
+depends=('gst-python' 'python-dbus' 'python-beautifulsoup4' 'python-pytaglib')
+source=("https://codingteam.net/project/bluemindo/download/file/bluemindo-$pkgver.tar.gz"
+ "makefile.patch")
+sha256sums=('e405c881feeb43f8126988403e1c1008ee5341c8faae90d5e671d9075c89fe5c'
+ '3f8758bd2255966af796937902e1ff5064df3f34283172eaee8b28d855fb0747')
+
+prepare() {
+ cd $pkgname-1.0RC1
+
+ patch -p1 -i ../makefile.patch
+}
+
+package() {
+ cd $pkgname-1.0RC1
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..b330da2d63fb
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,10 @@
+--- a/Makefile 2016-02-25 00:10:20.000000000 +0100
++++ b/Makefile 2016-12-23 11:13:38.466239971 +0100
+@@ -13,6 +13,7 @@
+
+ install:
+ install -d $(LOCALEDIR) $(BIN) $(DATADIR)/bluemindo $(DATADIR)/bluemindo/image $(DATADIR)/bluemindo/glade $(DATADIR)/bluemindo/src
++ install -d $(DATADIR)/applications $(DATADIR)/pixmaps $(MANDIR)/man1
+
+ install -m644 data/image/*.png $(DATADIR)/bluemindo/image
+ install -m644 data/glade/*.ui $(DATADIR)/bluemindo/glade