summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriele Musco2021-12-03 09:39:05 +0100
committerGabriele Musco2021-12-03 09:39:05 +0100
commitcc41b874e80dce1bb4c031fc6abafb2d86828600 (patch)
tree78767c00b1e9e0d2e051ca123054a6bbaa8ae9f6
downloadaur-cc41b874e80dce1bb4c031fc6abafb2d86828600.tar.gz
first release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8b1bc1fb221
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = blueprint-compiler-git
+ pkgdesc = A markup language for GTK user interfaces
+ pkgver = d0cf13b
+ pkgrel = 1
+ url = https://jwestman.pages.gitlab.gnome.org/blueprint-compiler
+ arch = any
+ license = LGPL3
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ depends = python
+ depends = gtk4
+ provides = blueprint-compiler
+ conflicts = blueprint-compiler
+ source = blueprint-compiler::git+https://gitlab.gnome.org/jwestman/blueprint-compiler.git
+ sha256sums = SKIP
+
+pkgname = blueprint-compiler-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53da0de54db9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/jwestman/blueprint-compiler
+
+pkgname=blueprint-compiler-git
+pkgver=d0cf13b
+pkgrel=1
+pkgdesc="A markup language for GTK user interfaces"
+arch=('any')
+url="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler"
+license=('LGPL3')
+depends=('python' 'gtk4')
+makedepends=('git' 'gobject-introspection' 'meson')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://gitlab.gnome.org/jwestman/blueprint-compiler.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}
+